WordPress.org

Ready to get started?Download WordPress

Forums

WordPress 2.0.6: Feedburner issue, and fix (5 posts)

  1. MichaelH
    Member
    Posted 7 years ago #

    These words for the WordPress Guru, Mark Jaquith:

    Despite two release candidates and several weeks of availability for testing, a bug sneaked into WordPress 2.0.6 that affects the serving of 304 Not Modified feeds. It’s actually related to the Server 500 error issue that 2.0.5 had (and 2.0.6 fixes)… it just affects a different set of people.

    See Mark's post and fix: WordPress 2.0.6 Feedburner issue and fix

    The fix is to comment-out lines 2231,2233,2234 in wp-includes/functions.php. Please note that 2232 is left alone. The four lines 2231-2234 should look like this:

    // if ( substr(php_sapi_name(), 0, 3) == 'cgi' )
    @header("HTTP/1.1 $header $text");
    // else
    // @header("Status: $header $text");

    [edited]

  2. whooami
    Member
    Posted 7 years ago #

    you mean wp-includes/functions.php

    it works, btw, I hadnt even checked to see if my feeds were working. They were blank until I made a new post.

  3. MichaelH
    Member
    Posted 7 years ago #

    Thanks for the excellent follow-up whooami. I've fixed my comment above.

  4. ComputerGuru
    Member
    Posted 7 years ago #

    Another (alternative) workaround and more info on this bug is available at The NeoSmart Files: http://neosmart.net/blog/archives/317

  5. ericjohnolson
    Member
    Posted 7 years ago #

    If anyone has any questions on this and would like to chat with someone at FeedBurner please feel free to shoot me a note. Thanks to all of you who have put together workarounds. We really appreciate it!

    Cheers,
    Eric

    ----
    Eric Olson
    Publisher Services - FeedBurner
    E-mail: erico@feedburner.com
    Office: 312.756.0022 x2034
    Mobile: 508.335.9221
    Skype/AIM: EricJohnOlson

Topic Closed

This topic has been closed to new replies.

About this Topic