WordPress.org

Ready to get started?Download WordPress

Forums

WordPress 2.0.4 to 2.1 Issues (52 posts)

  1. TimKing
    Member
    Posted 7 years ago #

    I've upgraded my installation from 2.0.4 to 2.1.

    The original WordPress installation was 2.0.4 installed via cPanel Fantastico. I have read all the relevant information on the subject of upgrading a fantastico installation.

    The installation went through without a hitch, easily installed no errors and all plugins turned on correctly.

    HOWEVER.

    Now when I log into the admin section I have reduced features!

    For a Start...

    Writing a post DOES have the tabs, Yet there are a heap of things missing, (all extended buttons eg images/links/alignment.) there are no options!

    I cannot see the new Upload area.

    So there are a heap of things that the new version (2.1) touts that do not show up for me.

    Is there something that I need to change to fix this?

    Any help on this would be great!

  2. TimKing
    Member
    Posted 7 years ago #

    Oh I forgot to mention that these are the versions of my PHP and MySQL:

    PHP version 4.4.4
    MySQL version 5.0.24-standard'

  3. kodekitten
    Member
    Posted 7 years ago #

    I am experiencing the exact same thing with the TinyMCE, and it seems that we're not the only ones. I don't get any particular javascript errors in Firefox -- just lots of icons missing. The only ones present are bold, italics, split, spell check and help.

    Here's a screenshot

  4. TimKing
    Member
    Posted 7 years ago #

    Yep thats exactly what I get, also the extended features of the installation (2.1) are not present, aka the new upload area and other nice things!

  5. TimKing
    Member
    Posted 7 years ago #

    I sure hope there is an easy fix for this!

  6. Matt Bernius
    Member
    Posted 7 years ago #

    Ditto the above. Posting works fine, but the editor was missing all but the functions mentioend in the previous post.

  7. kodekitten
    Member
    Posted 7 years ago #

    I reverted to 2.0.7 so that I could regain the functionality, but somehow all the javascript in the Write screen broke and one image plugin stopped working entirely. Fun times tonight.

  8. windlotus68
    Member
    Posted 7 years ago #

    I'm having similar problems in Firefox 2.0 (Mac). I see the buttons TimKing does; the photo uploader does appear for me, but I haven't even seriously considered trying it yet.

    EDIT: I upgraded by hand through FTP. Everything else appears to be working fine, other than a hiccup in my recent posts listing that I assume has to do with syntax changes(?).

  9. kodekitten
    Member
    Posted 7 years ago #

    I just had a friend tip me off that he sees the full menu in IE, so this seems like a Firefox incompatibility, since his Firefox doesn't show it either.

    Edit: Huzzah! By going into my Firefox settings, I've been able to get the TinyMCE menu to re-appear in OS X:

    Firefox > Options > Content > Enable Javascript > Advanced > Make sure all these options are checked.

    Credit goes to dracolich for this fix. Hope this works for everyone!

  10. windlotus68
    Member
    Posted 7 years ago #

    Thank you, thank you, thank you both!

    YMMV on this one, but just to experiment I checked all the boxes, reloaded the Write page, and the buttons were there. I unchecked all the boxes, reloaded it again...and they were still there. I shut down and reopened Firefox (everything still unchecked)...still buttons. I couldn't begin to guess why that is, but it worked. :)

  11. Xander
    Member
    Posted 7 years ago #

    Hmm, ah... pages in the manage page view are now listed in reverse order of importance? Is that right?

  12. tlj
    Member
    Posted 7 years ago #

    I'm using Firefox 2.0.0.1 on OS X 10.4.8. I experienced the same problem with the buttons post editor. Clearing my browser cache solved the problem for me.

    Based on experience trying to deal with issues like this for the company that I work for I would suggest as a last resort trying to clear your cache. I would suggect not doing this as your first troubleshooting step because it does not reallly narrow down the problem too much.

    Unfortunately, I'm relatively unfamiliar with debugging client side code in Firefox (IE only product where I work) so after trying a few things suggested here I thougth I'd see if clearing the cache helped.

    For the record I had version 2.0.6, 2.0.7, 2.1 RC 1 and 2.1 RC 2 on my web for testing. I didn't pick this up because I primarily use safari.

    If there is no resolution to this soon I'd be happy to see if its a combination of previous versions pages cached in firefox on my PC that caused the problem, but I'm unable to get to this for a couple of days.

    Anyway, hope this helps someone.

  13. TimKing
    Member
    Posted 7 years ago #

    AWESOME, so we have a couple of solutions.

    Just remember that you can press CTRL + F5 to dump the cache of ONLY the page that you are on in Firefox, if you do that to your write post page you won't have the problem any more!

  14. thedazellama
    Member
    Posted 7 years ago #

    I had the same problems and they were fixed when I replaced the wp-admin/post-new.php file. Don't know why. Just worked.

  15. momocat
    Member
    Posted 7 years ago #

    After i got all the tiny editor buttons back to life i have a new problem.

    I can't edit URLs in WYSIWIG mode. There is no "okay" and "cancel" button in Firefox 2.0.0.1. The "x" to close that windows does not work too!

  16. Aarne Toompark
    Member
    Posted 7 years ago #

    Am I only one who is missing "Show HTML" button in Rich-editor? It was on place with 2.0.7 but in 2.1 it’s missing. Code-editor is not showing full HTML.

  17. kodekitten
    Member
    Posted 7 years ago #

    Momocat--

    That java window for the URLS is equally buggy for me. I have to refresh the page to get it to go away and abandon trying to use it.

  18. Sajonara
    Member
    Posted 7 years ago #

    I updated to newest Java Runtime Environment 1.5.10 at http://www.sun.com

    Try to upgrade. Close the browser and retry things. For that I upgraded this and did change the Javascript options as mentioned before it worked for me.

  19. momocat
    Member
    Posted 7 years ago #

    http://wordpress.org/support/topic/101723?replies=20

    Sajonara , can you edit URLs with WYSIWYG-Editor?

  20. Sajonara
    Member
    Posted 7 years ago #

    Yes, now I can edit URLs.

  21. jillesvangurp
    Member
    Posted 7 years ago #

    I'm having lots of problems as well making the editor work properly/as advertised in firefox 2.0.1. It is quite obvious to me now that this thing hasn't been properly tested. Switching to IE7 does not seem to help either. Considering this is the first time I load wordpress in that browser, I think we can safely assume it is not a browser caching problem. I haven't touched any settings in IE7 for the simple reason I only use that browser to run windows update (i.e. I've launched into it twice so far since upgrading a few weeks ago).

    I've deleted all files except for uploads, configuration and two plugins (google analyticator and open id delegation) that are non editor related. So obviously that is not the issue either.

    So when cache and installation seem to be fine and others are also experiencing issues my conclusion becomes that the problem is not on my side.

    The editor should work with stuff in the javascript options of firefox disabled (the damn dialog is there for a reason and I have most stuff disabled there for the same reason!). Also it should be compatible with any normal preferences in firefox and IE.

    Finally, spellchecking is pointless considering firefox 2.0 already ships with spellchecking included and the fact that many users blog in different languages than english. Additionally many users of other/older browsers install browser addons to add spellchecking which obviously conflicts with a website overriding this. Therefore this should be an optional feature (default disabled) or a plugin.

    Rather than continuing whining about it, maybe a 2.1.01 with the old editor would be a more appropriate solution for the moment until the new editor has been properly tested and fixed. IMHO this should be released ASAP before more users run into these problems. Alternatively, 2.1 could be unreleased with a nice apology/explanation on the blog.

    Stuff like this happens, I'm not blaming anyone and just want to get things fixed.

  22. faustina
    Member
    Posted 7 years ago #

    I'm not sure what to do. None of the solutions posted here work for me. With rich text turned off, all is fine and working. With it on, I see the tabs that say "visual" and "code" but neither are click-able. I have enabled all java options in my browser. I have emptied my cache. I have reloaded the page many times. I have disabled my plugins, sitll not working at all. I am using FireFox 2.0.0.1

  23. jillesvangurp
    Member
    Posted 7 years ago #

    I must appologize for my previous, lengthy post. I was wrong and withdraw my previous statement about things not being tested properly. Also much of the advice related to javascript settings here is not correct either so I was wrong to criticize that too.

    The solution is here: http://wordpress.org/support/topic/101817?replies=8: enable visual editor in your user profile. A bit a odd place for this setting and sort of unexpected that it turns itself off while upgrading.

    Everything seems to work properly now.

    BTW updating java obviously does not help since wordpress does not contain a single line of java code. Javascript is not the same as Java. Upgrading it doesn't hurt either of course, I'd suggest updating to 1.6.0 if you want to upgrade.

  24. faustina
    Member
    Posted 7 years ago #

    That is not the solution to my problem, I still have all those issues with the visual editor selected in my profile!

  25. momocat
    Member
    Posted 7 years ago #

    I solved the remaining problems with the editor via cleaning up the browsers cache. Firefox -> Extras -> Delete Private Data -> Activate Cache -> Delete private Data now!

    I did not modify my extended javascript options at all!

  26. faustina
    Member
    Posted 7 years ago #

    Deleting cache does nothing for my problems. I have tried all of these things with no avail.

  27. dsi0743
    Member
    Posted 7 years ago #

    More and more stranger... I tried on IE7 at my office... All was working well. Visual editor was ok.

    Now, I trying again with IE7 from my home... no visual editor... :-(

    Firefox 2.0.1 doesn't work in both my office and home...

    None of the "soluces" explained above does anything for the proble...

    A very problematic migration to the new version...

    If no solution is found quickly I will switch to another software (like DotClear)... but I really prefer WordPress...

  28. flamingbear
    Member
    Posted 7 years ago #

    Okay now we've solved part of my problem, I turned the WYSIWYG back on in the user profile. But now my "Viper's Video Quicktags" buttons are gone. Everything was fine in 2.04 & the buttons were present in 2.1 - I can tag manually and everything still works. Just no lazy shortcuts.

    http://www.flamingbear.ca/blog

  29. flamingbear
    Member
    Posted 7 years ago #

    Ooops sorry should have said that the tags were there until I turned on the WYSIWIG, sorry for the confusion.

  30. dsi0743
    Member
    Posted 7 years ago #

    The solution to solve WYSIWYG Editor problem for IE and Firefox is here : http://trac.wordpress.org/ticket/3144

Topic Closed

This topic has been closed to new replies.

About this Topic