WordPress.org

Ready to get started?Download WordPress

Forums

wordpress-2.0.2 and wp-cache-2-0-17: Blank page problem (9 posts)

  1. sunilkhedar
    Member
    Posted 8 years ago #

    Hi,

    I have recently downloaded "wordpress-2.0.2.tar.gz" and "wp-cache-2-0-17.zip" to have the cache.

    I have followed all the instructions provided by wp-cache to install it.

    but once I activated wp-cache from wp-admin/plugins. The only this I got was a blank page. I tried to load the pages but, every page on my blog are blank.

    I there any bug in "wordpress-2.0.2.tar.gz" and/or "wp-cache-2-0-17.zip"?

    Or I am doing some thing wrong?

  2. angsuman
    Member
    Posted 8 years ago #

    Same here. Is wp-cache 2 unavailable in WordPress 2.02?

  3. arnee
    Member
    Posted 8 years ago #

    Hi,
    you have to edit the wp-cache-phase2.php. Search for "ob_end_clean()" and replace it with "ob_end_flush()".

    Best regards,

    Arne

  4. jfruh
    Member
    Posted 8 years ago #

    Hi there-

    I've seen the blank page problem intermittently with the WP and WP-Cache versions outlined above. Mostly it only happened when users attempted to post a comment, and then could be fixed if users changed the names entered in the comment field. However ... today the problem seems to have spread to the main page of the site! I have tried de-installing WP-Cache and replacing it with Statiscize Reloaded, with identical results. I made the change outline above in this thread, and still get the blank pages ... but the user can get the page by reloading, now. Still not acceptable, obviously. My ISP *requires* me to use caching because of the high traffic to my site and the burden it puts on PHP. HELP!

    jf

  5. Chris_K
    Member
    Posted 8 years ago #

    Do you have gzip compression turned on in options -> reading? Be sure to disable it.

    Have you tried going to options -> wp-cache and clearing cache and then resetting to defaults?

  6. jfruh
    Member
    Posted 8 years ago #

    I don't have gzip compression turned on. Clearing the cache doesn't seem to help, but I haven't gone back to the default settings yet; I guess I'll try that.

    Also, I realize now that the above fix (ob_end_clean() to ob_end_flush()) is just for PHP 5, yes? My host only uses PHP 4.something.

    jf

  7. yosemite
    Member
    Posted 8 years ago #

    If you haven't yet: Delete everything in wp-content/cache. Try again...

  8. mclapp
    Member
    Posted 7 years ago #

    arnee, that solution seems to have worked for me, thanks. i wonder why this wasn't included in the original code?

  9. mccain
    Member
    Posted 7 years ago #

    Arnee's fix worked for me. My install is WordPress 2.0.5 and wp-cache 2.0.17.
    The problem is apparently inherent with using PHP5

    For those on a Dreamhost server, the vanilla Dreamhost installation will come with this problem automatically. The one-click easy install defaults to php5, and anyone who clicks through it and wants to use the wp-cache plugin which comes with the default installation will need to make this config change.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags