WordPress.org

Ready to get started?Download WordPress

Forums

WordPress & Permalinks (9 posts)

  1. webdivauk
    Member
    Posted 8 years ago #

    I finally managed to get a new permalink structure in place however I had to put /index.php/ in front of it, however it's not what I want. For example I now get http://www.webdiva.co.uk/index.php/2005/10/09/webdiva-in-print/ when I really want http://www.webdiva.co.uk/2005/10/09/webdiva-in-print/

    I have mod_rewrite installed and I'm on an apache server, any ideas?

  2. Beel
    Member
    Posted 8 years ago #

    Remove it? You didn't explain why you had to add the index page.

  3. webdivauk
    Member
    Posted 8 years ago #

    I was following the instructions on the permalink section in wordpress. If I remove it I get 500 server errors on the links. I'm wondering if there is another option available to me as I dont want to have index.php stuck in the middle of the URI like that.

  4. webdivauk
    Member
    Posted 8 years ago #

    I was following the instructions on the permalink section in wordpress. If I remove it I get 500 server errors on the links. I'm wondering if there is another option available to me as I dont want to have index.php stuck in the middle of the URI like that.

  5. Cypher
    Member
    Posted 8 years ago #

    If you get 500 Server Errors when you remove the /index.php/ portion then you either don't have access to the .htaccess file or your host hasn't enabled mod_rewrite support in Apache.

    Using /index.php/ basically circumvents the use of those 2 things and allow you get "kinda" pertty URL's..

    Regards

  6. angsuman
    Member
    Posted 8 years ago #

    Check this article on permalinks. I think it addresses your needs.

  7. webdivauk
    Member
    Posted 8 years ago #

    Angsuman I've already read the above link and it doesn't provide a solution to my question where I'm trying to avoid having /index.php/, unless of course creating a php.ini would do the trick?

    I really don't want /index.php/

    NB - I've tried adding the php.ini file and it doesn't alter anything

    Talking about mod_rewrite it is enabled on my server and I can manually alter the .htaccess files, maybe there is something I need to add into the .htaccess that is not being added correctly.

  8. Yngwin
    Member
    Posted 8 years ago #

    Check with your host if they have mod_rewrite enabled and if you can use your own .htaccess...

  9. webdivauk
    Member
    Posted 8 years ago #

    Hey everyone thanks helping out. I manually edited my .htaccess and found a line I had manually added to make a redirect, I deleted it and it's working perfectly.

Topic Closed

This topic has been closed to new replies.

About this Topic