WordPress.org

Ready to get started?Download WordPress

Forums

Wordfence Security
Wordfence killed my site! (3 posts)

  1. thegamescabin
    Member
    Posted 1 year ago #

    Long story short, see the title!

    I keep getting three error codes above the header when wordfence is active, but I found that disabling firewall things solved it.

    Today, I tried to change a few things in the options, now when I go to login it has the errors above the login page and when i click login I get this:

    Warning: preg_match() [function.preg-match]: Unknown modifier '4' in /home/ctechwor/public_html/wp-content/plugins/wordfence/lib/wfUtils.php on line 517

    Warning: preg_match() [function.preg-match]: Unknown modifier '4' in /home/ctechwor/public_html/wp-content/plugins/wordfence/lib/wfUtils.php on line 517

    Warning: preg_match() [function.preg-match]: Unknown modifier '4' in /home/ctechwor/public_html/wp-content/plugins/wordfence/lib/wfUtils.php on line 517

    Warning: Cannot modify header information - headers already sent by (output started at /home/ctechwor/public_html/wp-content/plugins/wordfence/lib/wfUtils.php:517) in /home/ctechwor/public_html/wp-login.php on line 368

    Warning: Cannot modify header information - headers already sent by (output started at /home/ctechwor/public_html/wp-content/plugins/wordfence/lib/wfUtils.php:517) in /home/ctechwor/public_html/wp-login.php on line 380

    Warning: Cannot modify header information - headers already sent by (output started at /home/ctechwor/public_html/wp-content/plugins/wordfence/lib/wfUtils.php:517) in /home/ctechwor/public_html/wp-includes/pluggable.php on line 680

    Warning: Cannot modify header information - headers already sent by (output started at /home/ctechwor/public_html/wp-content/plugins/wordfence/lib/wfUtils.php:517) in /home/ctechwor/public_html/wp-includes/pluggable.php on line 681

    Warning: Cannot modify header information - headers already sent by (output started at /home/ctechwor/public_html/wp-content/plugins/wordfence/lib/wfUtils.php:517) in /home/ctechwor/public_html/wp-includes/pluggable.php on line 682

    Warning: Cannot modify header information - headers already sent by (output started at /home/ctechwor/public_html/wp-content/plugins/wordfence/lib/wfUtils.php:517) in /home/ctechwor/public_html/wp-includes/pluggable.php on line 876

    Is there anything I can do? Please also note that I am a complete novice, I don't know the first thing about coding and the fact my website has managed to stay on for the last 6 months is down to nothing more than sheer dumb luck.

    Would deleting the files from within cPanel solve the problem?

    If anybody could answer with a nice reply that is simple and easy, I would be forever in your debt, and if you happen to live within a reasonable distance to me, I'll take you for a beer/coffee/wine whatever you want.

    Cheers,

    Chris

    http://wordpress.org/extend/plugins/wordfence/

  2. W.P. Ginfo
    Member
    Posted 1 year ago #

    Disable the plugin by renaming it [put a '0' in front foldername]
    Check if that solves the problem.

    Find a working alternative

  3. midloman
    Member
    Posted 1 year ago #

    Check with your ISP to find out if PHP has been upgraded lately. The latest php releases whine about all sorts of things that were OK before.

    Please note that all of the output has been Warning: messages. These might or might not be important, but you can probably get back to a functioning site pretty quickly.

    You can suppress Warning messages in php.ini, .htaccess or index.php Check with your ISP on which is appropriate for your situation.

    It's also possible that you have turned on error reporting in one of your other plugins (that's what happened to me).

    Bottom line: you can turn those errors off if you want.
    Google search on "php warnings suppress"

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic