WordPress.org

Ready to get started?Download WordPress

Forums

Wordfence Security
[resolved] WordFence has stuck when scanning (8 posts)

  1. Horrgakx
    Member
    Posted 5 months ago #

    Hi all - I installed the latest WordFence program/software/thing* on to two of my sites. The first site it has found a problem with (and I don't know whether to restore the original file or not) but the second site it's been running for about an hour now, it's stuck on the following two items;
    - Scanning file contents for infections and vulnerabilities
    - Scanning files for URLs in Google's Safe Browsing List
    Should I just close the page and start it again?

    * Unfortunately I'm more of an end user; someone else set up my site for me but I'm trying to do my best running & updating it because they're not available.

    https://wordpress.org/plugins/wordfence/

  2. Wordfence
    Member
    Plugin Author

    Posted 5 months ago #

    Hi,

    Please note that it sounds like the Wordfence scan stopped on an item. It's not stuck and constantly consuming reseources even though it looks that way. The scan simply stopped. Just in case you were worried about your site being slowed down.

    Can you please go to the bottom of the Wordfence 'options' page. Click the link to test your Wordfence hosts available memory. Then post the results here.

    Regards,

    Mark.

  3. Horrgakx
    Member
    Posted 5 months ago #

    Thanks for your reply. The copy & paste is below.

    I could actually do with help with my 2x WordPress sites; 1 of them keeps sticking on the scan, and the other tells me that there are 3x modified files.

    I have no idea what I'm looking for and would even pay to have someone have a look at it.

    Anyway, here's the data;

    Wordfence Memory benchmarking utility version 4.0.3.
    This utility tests if your WordPress host respects the maximum memory configured
    in their php.ini file, or if they are using other methods to limit your access to memory.

    --Starting test--
    Current maximum memory configured in php.ini: 268435456
    Current memory usage: 38.50M
    Setting max memory to 90M.
    Starting memory benchmark. Seeing an error after this line is not unusual. Read the error carefully
    to determine how much memory your host allows. We have requested 90 megabytes.
    Completing test after benchmarking up to 80.25 megabytes.
    --Test complete.--

    Congratulations, your web host allows you to use at least 80.25 megabytes of memory for each PHP process hosting your WordPress site.

  4. Wordfence
    Member
    Plugin Author

    Posted 5 months ago #

    OK, looks like ou have 256M of memory which is plenty. Can you check your web server error log for messages when the scan stops and let me know what you see?

    Regards,

    Mark.

  5. Horrgakx
    Member
    Posted 5 months ago #

    Erm, I'm sorry I don't know how to do that :(

  6. Kerry
    Member
    Plugin Author

    Posted 5 months ago #

    Are your sites hosted with a company? If they are, you can log a call with the company and ask them to send you the server error log which will contain the error message that is preventing Wordfence from completing the scan.

  7. czeller
    Member
    Posted 4 months ago #

    I'm having the same problem- stuck on a scan that started yesterday morning. Deleted the plugin to try to start it over, but even with a fresh install, still says it's stopped at the same place from yesterday...

    Memory is fine as well, will try calling Godaddy- any other suggestions?

  8. czeller
    Member
    Posted 4 months ago #

    Hmmm, here is the result of the "test of the host's memory, it has some errors at the end:

    Wordfence Memory benchmarking utility version 4.0.3.
    This utility tests if your WordPress host respects the maximum memory configured
    in their php.ini file, or if they are using other methods to limit your access to memory.

    --Starting test--
    Current maximum memory configured in php.ini: 64M
    Current memory usage: 31.75M
    Setting max memory to 90M.
    Starting memory benchmark. Seeing an error after this line is not unusual. Read the error carefully
    to determine how much memory your host allows. We have requested 90 megabytes.
    Completing test after benchmarking up to 84.00 megabytes.
    --Test complete.--

    Congratulations, your web host allows you to use at least 84.00 megabytes of memory for each PHP process hosting your WordPress site.
    Error received: mysql_fetch_object(): supplied argument is not a valid MySQL result resource
    Error received: mysql_fetch_object(): supplied argument is not a valid MySQL result resource
    Error received: Undefined offset: 1
    Error received: Undefined offset: 0

Reply

You must log in to post.

About this Plugin

About this Topic