WordPress.org

Ready to get started?Download WordPress

Forums

Word 2007 blogging to WordPress (9 posts)

  1. Herby007
    Member
    Posted 8 years ago #

    I'm trying in Word 2007 Beta 2 to blog to WordPress 2.0.2 with this datas:

    Blogtype "Others"
    API "MetaWebLog"
    Blog Post URL "http://maennerseiten.de/blog/xmlrpc.php"

    But WP don't let me in - any other way?

  2. aonaich
    Member
    Posted 8 years ago #

    What sort of error message are you getting? Is your blog post URL pointing to the corret location for your xmlrpc.php file? Are you having problems trying to connect to WP or the image upload folder as there are known problems with that. If you are, make sure to select "Don't upload images in my blog post." in your blog account setup and try again.

    If there were no error messages, and your post is labelled as published in Word but does not show up in your blog, chances are that it is in there somewhere but ended getting posted in a weird date. For more info on that, click on "Help me fill out this section" in your blog account setup.

    Hope this was of some help. It hasn't been a bed of roses for me either!

  3. Herby007
    Member
    Posted 8 years ago #

    Thank you for your very quick answer!

    1. The xmlrpc.php-URL is correct.
    (Maybe I should mention: It is not a wordpress.com blog, it is a "normal" WP blog at my own server)
    2. Word trys to connect to the blog and than comes the Word error message:
    "Could not register Account. Most likley you are not connected to internet or the provider information is incorrect or the provider ist not compatible with word"

  4. steven_stern
    Member
    Posted 8 years ago #

    It is working for my blog. I found that I had to be very careful with the case of my user name and password. Although it (Word 2007) posts, it returns an error that it could not connect!

  5. aonaich
    Member
    Posted 8 years ago #

    Hi Herby007, hmm I haven't gotten that error before myself. My WP blog is also a 'normal' WP blog. Your username is admin with the correct password right? You might want to take a look at the known blogging issues here for Word 2007: http://officebeta.iponet.net/en-us/products/FX101517941033.aspx#24

    One thing that did the trick for me was to delete all my accounts, then follow this steo outlined in the known issues page before creating a new account:

    1. Click Start and then click Run to open the Registry Editor.
    2. Type regedit and click OK.
    3. Delete \\HKCU\Software\Microsoft\Office\Common\Blog

    When first registering an account I suggest leaving Step 3 as "Don't upload images in my blog post." It can really mess things up.

    Hope you get it working!

    Hi steven_stern, yeah it worked for mine too though I ended up with it posting to 1 Jan 1970, which was damn funny. Haven't had it returning an error like you have experienced when posting though.

  6. lleger
    Member
    Posted 8 years ago #

    Herby, try to "Publish as a Draft" first. For some reason Word only publishes to a draft for me. IDK, beta issues... I wrote an in depth tutorial here if anyone else wants to know how to do this.

  7. basho
    Member
    Posted 8 years ago #

    I found this to work as a draft only by using the following:

    http://WEBSITE/wordpress/xmlrpc.php

    I haven't been able to get images working, but I presume the idea is to have FTP access directly to the WP-content folder and use this to connect.

    I note the window help mentions:

    "Specify an http or ftp address for Word to publish pictures to. Post beta 2, we plan to have more options in this area."

  8. EpsteinLlewellyn
    Member
    Posted 7 years ago #

    I just worked up a tutorial for this using the latest release of Office 2007 (not the beta). I still had the image problems, so there are no "other options" as I can see. Still working that issue.

    To see my tutorial so far, with screencaps, go to:

    http://www.spittleandink.com/isis/img/wordblogging/wordblogging.htm

  9. EpsteinLlewellyn
    Member
    Posted 7 years ago #

    Tutorial updated with fix for using images!

    http://www.spittleandink.com/isis/img/wordblogging/wordblogging.htm

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags