WordPress.org

Ready to get started?Download WordPress

Forums

Woohoo, new update problem.. (12 posts)

  1. DominikSchwind
    Member
    Posted 10 years ago #

    Good morning, everybody.. :)
    See here:
    http://www.lostfocus.de/en/index.php
    I updated correctly from a 0.72-installation and the update-script didn't have any problems. I used the fix from
    http://wordpress.org/support/6/1461
    to access my admin interface.
    And now I seem to have problems with the mysql-query.
    Any ideas?

  2. Laughinglizard
    Member
    Posted 10 years ago #

    Can you be a little more specific about your problem with the mysql-query? I looked at your blog and everything seems fine.

  3. DominikSchwind
    Member
    Posted 10 years ago #

    Because stupid me uploaded the backup again without mentioning it here..
    I'll try it again as soon as I'm free, then I can give more details.

  4. DominikSchwind
    Member
    Posted 10 years ago #

    Okay, here is the problem: (also appeared with the build from 2004-01-06)

    <b>Warning</b>: Invalid argument supplied for foreach() in <b>/kunden/lostfocus.de/webseiten/lostfocus/de/wp-blog-header.php</b> on line <b>325</b>
    <b>Warning</b>: Bad arguments to implode() in <b>/kunden/lostfocus.de/webseiten/lostfocus/de/wp-blog-header.php</b> on line <b>328</b>
    <div id='error'>
    SQL/DB Error:
    [<span style='color: #007;'>You have an error in your SQL syntax near ')' at line 4</span>]
    SELECT DISTINCT
    ID, category_id, cat_name, category_nicename, category_description
    FROM wp_categories, wp_post2cat, wp_posts
    WHERE category_id = cat_ID AND post_id = ID AND post_id IN ()

    </div>
    <b>Warning</b>: Invalid argument supplied for foreach() in <b>/kunden/lostfocus.de/webseiten/lostfocus/de/wp-blog-header.php</b> on line <b>335</b>
    Weirdly enough, the same upgrade went smoothly on my machine at home.

  5. DominikSchwind
    Member
    Posted 10 years ago #

    I just installed a WP from scratch -> http://www.lostfocus.de/wp/
    Same Problem.
    Once again, that problem does not happen on my machine at home, even though PHP and MySQL have the same version number.

  6. DominikSchwind
    Member
    Posted 10 years ago #

    Problem solved, even though, I have no clue, why.
    I just deleted all cookies for my domain and now it works nicely.
    It seems to be an issue with MovableType-login cookies on the same domain?!
    Quite weird.

  7. eryanv
    Member
    Posted 10 years ago #

    I've had a similar message on a clean install from the 01-06-2004 nightly build. I get the following message on edit.php and index.php when there are no posts (ie you deleted the first post) or when there are posts but you search for a word that doesn't exist. I'd let the community have a look, except that I'm on a Dynamic IP and behind a couple of NATs.
    Warning: Invalid argument supplied for foreach() in /var/www/eryanv/wp-blog-header.php on line 325
    Warning: Bad arguments to implode() in /var/www/eryanv/wp-blog-header.php on line 328
    SQL/DB Error:
    [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 4]
    SELECT DISTINCT ID, category_id, cat_name, category_nicename, category_description FROM eryanv_categories, eryanv_post2cat, eryanv_posts WHERE category_id = cat_ID AND post_id = ID AND post_id IN ()
    Warning: Invalid argument supplied for foreach() in /var/www/eryanv/wp-blog-header.php on line 335

  8. DominikSchwind
    Member
    Posted 10 years ago #

    Try again after deleting all your cookies..

  9. eryanv
    Member
    Posted 10 years ago #

    Sorry, no luck, still exists.

  10. Alex King
    Member
    Posted 10 years ago #

    Well, the problem in the query is that there is nothing in the IN clause.

  11. lars
    Member
    Posted 10 years ago #

    "Woohoo, new update problem.." is not a particularly informative subject line.
    May I suggest you move the remainder of this discussion to the thread that I started, entitled No posts in a category: error.
    Thank you.

  12. Dougal Campbell
    Member
    Posted 10 years ago #

    I've just committed some changes to CVS which should fix this problem.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.