WordPress.org

Ready to get started?Download WordPress

Forums

Woocommerce Shop Page "Title" with All in One SEO (3 posts)

  1. fromenglandwithlove
    Member
    Posted 6 months ago #

    Why was the below page closed when there was no remedy?

    http://wordpress.org/support/topic/shop-page-issue-with-all-in-one-seo-plugin

    I installed Woocommerce, and I use All in One SEO (not yoast!)

    Same as the last post on the above forum link, I have exactly the same issue.... aka On the page I selected to use as the Woocommerce shop, the only page title that appears is "Products", and it's bl***y annoying ................and over 1 year later, Woocommerce "still" hasnt solved the problem (which would probably just be a simple bit of code to put in a next update), and obviously as I'm just using the standard free version, there's no way to contact them about the problem.

    Can any glorious human-being provide the right file to hack to change this? I need to hard code this in ASAP. I want: Shop | Website as the page title for the Shop page, not "Products"....... sigh


    This post goes out to everyone using all in one, and woocommerce

  2. manjitsingh.rvtech
    Member
    Posted 5 months ago #

    GO to AIOSEO >Performance and try disable the Force Rewrite.
    I Hope this will resolve your

  3. iTaylorJay
    Member
    Posted 3 months ago #

    I've finally found a solution that uses the aioseop_title filter in All in One SEO Pack (found here) - http://wordpress.org/support/topic/archive-title-not-being-rewritten

    In short you add this to your themes functions.php file -

    add_filter( 'aioseop_title', 'manual_rewrite_custom_titles' );
    function manual_rewrite_custom_titles( $title ) {
        if ( is_post_type_archive() ) {
            $postType=get_post_type('Products');
            $title = "Whatever you want the Title to be";
        }
        return $title;
    }

    This doesn't seem to conflict with any other re-writes that AIOSEO is doing. And you don't have to disable 'Force Rewrite'

Reply

You must log in to post.

About this Topic