WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
Woocommerce Shop Page Title (10 posts)

  1. roos3342
    Member
    Posted 9 months ago #

    I've searched around a bit and I have seen some discussion of this, but I can't get to a solution that enables this to be fixed on my site.

    You can see what I'm talking about at http://www.mintclothingcompany.com/shop/

    I would like the title to say: Products | Mint Clothing Company

    Currently w/ AIOSEO activated it says ProductsMint Clothing Company

    If I deactivate AIOSEO, the title shows correctly. It seems like I'm missing something obvious, but I just can't find it!

    Please let me know if anyone has a solution!

    P.S. - This is not the home page.

    Thanks!

    http://wordpress.org/plugins/all-in-one-seo-pack/

  2. roos3342
    Member
    Posted 8 months ago #

    Can anyone help me on this? What am I missing?!?!?!

  3. Peter Baylies
    Member
    Plugin Author

    Posted 8 months ago #

    roos3342,

    I've tested this; for me, it just says "Products". What do you have set for Use Original Title in your General Settings, what do you have set for Force Rewrites under Performance, and what does the title tag look like in your header.php?

  4. roos3342
    Member
    Posted 8 months ago #

    Hi Peter,

    I'm not sure why you would see something different than me? I'm seeing ProductsMint Clothing Company in firefox, safari and chrome.

    For use original title I have that set to enabled. For Force Rewrites under performance, that is also set to enabled.

    My header title tag looks like this:
    <title><?php wp_title( '|', true, 'right' ); ?></title>

    Thanks for looking at this, appreciate it!

  5. roos3342
    Member
    Posted 8 months ago #

    Hi Peter, I was wondering if you had any more thoughts on this?

    thanks.

  6. Peter Baylies
    Member
    Plugin Author

    Posted 8 months ago #

    roos3342,

    Try setting Use Original Title to Disabled and see if that fixes this issue.

  7. roos3342
    Member
    Posted 8 months ago #

    Doing that makes the title just say "Products". I will leave it like that for now. It's better than it was. I wish I could figure out tho how to make it show Shop | Mintclothing Company without having to deactivate the All in one SEO plugin.

    If I find anything else, I will post here.

  8. Peter Baylies
    Member
    Plugin Author

    Posted 8 months ago #

    I assume you have the Site Title in WordPress Dashboard Settings -> General set to "Mint Clothing Company" as well?

  9. roos3342
    Member
    Posted 8 months ago #

    Yes sir, you are correct.

    Thanks for your help.

  10. solosails
    Member
    Posted 2 weeks ago #

    I had a similar problem, and added this to my themes functions.php which sorted it out...

    // Change page title for Shop Archive page
    add_filter( 'wp_title', 'title_for_shop' );
    function title_for_shop( $title )
    {
      if ( is_shop() ) {
        return __( 'WHATEVER YOU WANT THE PAGE TITLE TO BE HERE' );
      }
      return $title;
    }

    Hope that may help

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.