WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] WooCommerce plugin v2.0.4 - very SLOW? (7 posts)

  1. ewdesigngroup
    Member
    Posted 1 year ago #

    We have recently built a small commerce site with only about 30 products with variations. We are currently using:

    • WordPress 3.5.1
    • WooCommerce plugin v2.0.4
    • A child theme of WooThemes "Shelflife"
    • PayPal Standard
    • W3 Total Cache plugin (to help with speed)
    • VPS DreamHost server

    We had to move the site over to VPS. The site was so sluggish, it was though you were on the old dial-up modem. On VPS currently most of the activity is below 1GB. It alternates between being below 500MB and just below 1GB. And there have been 2 spikes since setup that went up to 1.5GB and 1.8GB.

    We have installed a W3 Total Cache plugin that helped a little bit, but the site is still too slow.

    We also wanted to use PayPal Advanced so we purchased "WooCommerce PayPal Payments Advanced Gateway" plugin, but that opened up a whole new can of worms, so we had to revert back to PayPal Standard. I will save this for another Topic.

    http://wordpress.org/extend/plugins/woocommerce/

  2. box
    Member
    Posted 1 year ago #

  3. ewdesigngroup
    Member
    Posted 1 year ago #

    Update: We did extensive testing - bumped up server speed, added page and CSS caching, cleaned up lots of other stuff. This morning I realized we need to roll back to the basics to find the problem. First I removed lots of widgets, it helped some. Then I thought the speed issue might be caused by the theme we are using ("Definitions") as a parent theme. Sure enough that was the problem. As soon as we removed it and tried out just a basic WP twentytwelve, the site was flying fast!!!
    Wishlist: for WooThemes to offer a clean, stripped-down theme such as WP twentytwelve for those of us who like to create our own child themes.
    Conclusion: WooCommerce plugin v2.0.4 is working just fine without the bloated themes.

  4. mikejolley
    Member
    Plugin Author

    Posted 1 year ago #

    Good idea about the stripped down theme, thanks. Maybe based on _s

  5. ewdesigngroup
    Member
    Posted 1 year ago #

    @mikejolley - we have used "_s" in the past, great theme. We should consider using it for this project.

    This experience just proves again that pre-baked themes are good for some, but not for web designers/developers. Since we end up overriding most of the styles anyways, it just creates a bigger monster. I've learned my big lesson: when all else fails - to go back to the basics.

  6. smoppl
    Member
    Posted 1 year ago #

    Originally using the Builder Theme, updated the woocommerce plugin and received an error stating my theme was not compatible. I then switch to a woocommerce theme "Whitelight" same problem. I am now using a third party theme "Modernize" and the issues are still occurin. Please advise what needs to be done.

  7. ewdesigngroup
    Member
    Posted 1 year ago #

    @smoppl -
    You might want to delete the plugin and install it fresh, maybe something got corrupted during the upgrade.
    What does your error message say exactly? I would recommend to test things out with a WP twentywtelve theme, just to see if that works. If you still get the same error message then it might be something else. If twentytwelve works, then it would mean the themes you are using are the problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic