WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
WooCommerce Paypal auto return (8 posts)

  1. chucksincharge
    Member
    Posted 1 year ago #

    I have tried everything to get WooCommerce to return to my website automatically after a purchase but it will not work.

    WordPress 3.5.1
    WooCommerce v2.0.7
    I am using PayPal Standard.
    I have turned on auto return and set up an address even though WooCommerce seems to override this with the "Thanks" page which I am perfectly alright with.

    Currently after a purchase is complete it goes to a page that reads like this:

    Thanks for your order

    Charles, you just completed your payment.
    Your transaction ID for this payment is: "id here"

    We'll send a confirmation email to "email address here".

    Return to "payment account email address"
    Go to PayPal account overview
    Add funds from your bank

    Not only does it not return me to my site, but the link uses my PayPal stores email address in the return link and for the title of the page. Now if I do click that link, it will return me to the "Thanks" page specified in WooCommerce.

    Any help is greatly appreciated.

    -Charles

    http://wordpress.org/extend/plugins/woocommerce/

  2. chucksincharge
    Member
    Posted 1 year ago #

    Anyone?

  3. Devin Walker
    Member
    Posted 1 year ago #

    Same issue here - I'll post back if I find out anything on this... big hastle. Are your products digital? I did notice PayPal states:

    Note: If you have turned on Auto Return and have chosen to turn on PayPal Account Optional for new users, a new user will not be automatically directed back to your website, but will be given the option to return.

    I think some users may not be using a PayPal account to purchase items and therefore are NOT being auto redirected back to checkout complete. BUT, I have not had one successful PayPal purchase completed without me having to manually go in...

  4. toposwope
    Member
    Posted 1 year ago #

    Can someone at WooCommerce support please take a look at this bug, there has been no response for 2 months.

    I understand that auto return will not work for new users if PayPal Account Optional for new users is turned on. That's fine.

    The problem is, as stated by Charles above, that the return link after payment uses my PayPal stores email address for the title of the page and NOT the title of the website. It is very confusing for the customers and must be a bug because it is not logical that it would be designed this way.

    Current: Return to example@example.com
    Should be: Return to 'My Website Title'

    I would really appreciate assistance on this.

    TIA,
    Nik

  5. Devin Walker
    Member
    Posted 1 year ago #

    toposwope - I was having a similar issue. Ensure all fields are properly entered in PayPal and the email used matches the primary email in PayPal. It was a bit difficult to figure out but I eventually got mine working properly.

  6. toposwope
    Member
    Posted 1 year ago #

    Hi Devin,

    I am using the primary PayPal email in my Woocommerce settings and I have gone through my PayPal profile a number of times. Do you recall what field it was that you had to change?

    There only seems to be 1 place in the PayPal profile to enter an email address (add/edit email) so not sure where it could be getting it from other than from WooCommerce.

  7. FD123
    Member
    Posted 1 year ago #

    Same issue again.

    The return address should not show my email address. Any help would be great!

  8. WebshopLogic
    Member
    Posted 7 months ago #

    Hi,

    We had the same issue.

    Our solution is published here:
    http://webshoplogic.com/tips-and-tricks/solve-woocommerce-paypal-auto-return-problem/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic