WordPress.org

Ready to get started?Download WordPress

Forums

Woocommerce new registration not sending email to admin (7 posts)

  1. jackod
    Member
    Posted 1 year ago #

    First, when I create a New User in the Add New User WordPress backend, the admin does receive the New User Registration email successfully. However, when someone registers on the site itself via the woocommerce My Account page the admin does NOT receive the New User Registration email at all. All other forms and emails are being received by customers and admin successfully, so that is all working fine. The User is being created when they register directly on the site, so that is fine, but the admin is not getting the New User Registration email.

    http://www.odonnell-books.com

    Anybody else encounter this and find the solution to fix it?

    Thanks.

  2. interblend
    Member
    Posted 1 year ago #

    I have the same issue. Tried different mailing plugins, but it didn't work. Everything else is working fine. Only that one email.

    Maybe someone have a solution?

    Best regards,
    Arturas
    http://www.vdizainas.lt

  3. toto
    Member
    Posted 1 year ago #

    The solution is in functions.php add code:

    // Woocommerce New Customer Admin Notification Email
    add_action('woocommerce_created_customer', 'admin_email_on_registration');
    function admin_email_on_registration() {
        $user_id = get_current_user_id();
        wp_new_user_notification( $user_id );
    }

    PLS test the solution!

  4. trewknowledge
    Member
    Posted 11 months ago #

    Works for me. Thanks!

  5. wudza
    Member
    Posted 11 months ago #

    Hi everyone!
    Sorry for off-topic message but is it possible to modify the suggested code above from "toto" post for sending the notification to admin for ANY new order created by customer:
    right now it working only for ''real " goods and vitrual&downloadable goods in woocommerce . In my case I use only virtual goods

    Appreciated for any help!

  6. WPyogi
    Volunteer Moderator
    Posted 11 months ago #

    @wudza - please start a new thread rather than posting in an outdated one - you can include a link to this thread if it's relevant. This thread is also not even on the WC forum - so post here:

    http://wordpress.org/support/plugin/woocommerce#postform

  7. rookpsu
    Member
    Posted 11 months ago #

    @toto - excellent quick fix my man. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic