WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce Menu Cart
[resolved] "WooCommerce Menu Cart depends on WooCommerce to work" (21 posts)

  1. junkfood
    Member
    Posted 1 year ago #

    I've installed the plugin to my multisite network, but all of my sites have a message at the top that reads "WooCommerce Menu Cart depends on WooCommerce to work!" even though I have WooCommerce installed and working for all. Is there another activation step that I'm missing?

    Here's one of the sites in question (still in development): http://adamssandbox.com/.

    http://wordpress.org/extend/plugins/woocommerce-menu-bar-cart/

  2. Ewout
    Member
    Plugin Author

    Posted 1 year ago #

    Multi-Site is on our todo list, and currently not supported yet.
    If you have activated WooCommerce and just want to enable the plugin, you can remove everything from line 155 and onwards in woocommerce-menu-cart.php, and just leave $wcMenuCart = new WcMenuCart(); (which will fire the plugin).

  3. junkfood
    Member
    Posted 1 year ago #

    Thanks. That turned on the plug-in for me, but it's not actually working. Not sure if it's something to do with the multisite or not. Just set options for main site and it doesn't work there.

    All I want to do is turn off the price. It would be nice if I could add a quantity of items in the cart too.

  4. Ewout
    Member
    Plugin Author

    Posted 1 year ago #

    This is likely to be a multi-site issue. We will try to tackle this in the next release (we're releasing a version that supports multiple wordpress e-commerce plugins this week).

    btw, looks like your also using another plugin for the cart totals in the menu, just make sure that you're looking at the right menu item.

    Let us know if you have any other questions!

  5. junkfood
    Member
    Posted 1 year ago #

    Really? Interesting. I'll have to look at what other plugins in use are affecting the cart. Perhaps there's a conflict, and that could be causing the issue. Thanks.

  6. Ewout
    Member
    Plugin Author

    Posted 1 year ago #

    There's a <ul class="mini-cart"> in your navigation bar, whereas our plugin adds a
    <li> item to the menu you have selected in the settings page (assuming you did select a menu there).</li>

  7. junkfood
    Member
    Posted 1 year ago #

    Thanks. I'll have to take a look. Could be the theme adding that. I got yours to show up, but only with "1 Item" and not the icon. However, it crashed IE every time.

    I'll dig around and see if I can find the conflict.

  8. mheerema
    Member
    Posted 1 year ago #

    Any sense of when the next release, with multisite support, will be released?

  9. Jeremiah
    Member
    Plugin Author

    Posted 1 year ago #

    Hey guys! So I've been digging into how multisite menus work and it sounds like they operate a little different for everyone, depending on your use case. Are you using (or do you want to use) one unified menu across all sites? If so, there's a plugin that may be able to help with this. I read about it here: http://wordpress.org/support/topic/adding-a-global-menu-for-a-multisite-installation

    and the plugin is found here: http://wpmututorials.com/plugins/networkwide-menu/

    I'm completely unfamiliar with WP multisite, so any feedback on how your menus are currently setup and how you want them to work would be great!

    Jeremiah

  10. Creight
    Member
    Posted 1 year ago #

    We're using multisite and have the same problem. Only, the plugin was working 100% yesterday before I updated to WC 2.0.9 - since the update I get the "WooCommerce Menu Cart depends on WooCommerce to work".

    I really like the plugin and hope you get it to work. Thanks.

  11. Jeremiah
    Member
    Plugin Author

    Posted 1 year ago #

    Hi creight,

    Does the plugin still display in your menu, and could you give me a link to your site? Looks like WC 2.0.9 was made WordPress 3.6 compatible which might be the issue. We haven't gotten around to WP 3.6 compatibility yet and it looks like 3.6 may change the way menus work a bit.

  12. Creight
    Member
    Posted 1 year ago #

    Hey Jeremiah,
    No the plugin is no longer visible. http://flej.com/flej
    BTW we are still on WP 3.5.1 if that helps.

  13. Jeremiah
    Member
    Plugin Author

    Posted 1 year ago #

    Hi creight. Could you login to your WordPress site, navigate to plugins -> Editor and select the WooCommerce plugin from the dropdown in the upper right corner? What is the directory of the first file in the right hand bar? It should look like: woocommerce/woocommerce.php

  14. Creight
    Member
    Posted 1 year ago #

    Yip - it is: woocommerce/woocommerce.php

  15. Ewout
    Member
    Plugin Author

    Posted 1 year ago #

    Hey guys, I prepared a debugging version that could help solve this problem. It prints out a list of active plugins together with the "WooCommerce Menu Cart depends on..." message. If you remove the old version and install this one, you can email the list of plugins to support@wpovernight.com and we can review (it's better not to post this list to an open forum for possible vulnerabilities).

    You can grab the debugging version here.

    Hopefully we can resolve this quickly!

  16. Creight
    Member
    Posted 1 year ago #

    Howzit Ewout,
    I uploaded and activated the debugging file but it didn't list any plugins?

    It just says:

    WooCommerce Menu Cart depends on WooCommerce to work!
    Debug:

    Let me know if I can help further.

  17. Ewout
    Member
    Plugin Author

    Posted 1 year ago #

    That's interesting, but at least brings us a bit further. Do you have WooCommerce installed as a sitewide plugin?

    Here is a version that also checks for sitewide plugins. Thanks for helping us trying to fix this issue!

  18. Creight
    Member
    Posted 1 year ago #

    Ok, that picked up eight items (plugins?) which I have emailed to the address above.

  19. Ewout
    Member
    Plugin Author

    Posted 1 year ago #

    It looks like we've found a (temporary) solution, which is to remove the function that checks if WooCommerce is active, which worked for @creight.

    You can download this version here. Uninstall/deactivate any previous versions of WooCommerce Menu Cart before installing.

    Please report back in this thread if this fixes the issue for you too!

  20. Jeremiah
    Member
    Plugin Author

    Posted 1 year ago #

    So far 4/4 people that have tried this fix are up and running, so we're probably good to go. @junkfood if you have any other issues let us know, otherwise I'm marking this as resolved.

  21. thaivia
    Member
    Posted 7 months ago #

    Multi-Site is on our todo list, and currently not supported yet.
    If you have activated WooCommerce and just want to enable the plugin, you can remove everything from line 155 and onwards in woocommerce-menu-cart.php, and just leave $wcMenuCart = new WcMenuCart(); (which will fire the plugin).

    This worked for me, thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic