WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Woocommerce lightbox stopped working (15 posts)

  1. habicht
    Member
    Posted 1 year ago #

    I have woocommerce installed and all of the sudden the lightbox isn't working on the product page. I have the "Enable WooCommerce lightbox on the product page" checked, but when clicked, the image opens up on a new page.

    Help!

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    Have you tried posting on WooCommerce forums?

  3. habicht
    Member
    Posted 1 year ago #

    Yes, but I didn't see an answer there.

  4. FishFush
    Member
    Posted 1 year ago #

    I am running MyStile with WooCommerce but it won't save when I check the box:

    "Enable WooCommerce lightbox on the product page"

    I save, and then return to the page and it's been unchecked.

    Also, when I click a product image, first I get a lightbox which has rounded corners and the close (X) button at the top-right corner, when I close that, I get another one under it, the design is a bit different, with the close (X) button in the bottom-right, and a resize button in the top-right. Very strange.

    Not sure what to do.

  5. FishFush
    Member
    Posted 1 year ago #

    It seems that the one with rounded corners is the WooCommerce lightbox, and the other is something from the theme: "Enable the PrettyPhoto lighbox script on images within your website's content."

    Even though the WC one is un-ticked, it still appears always. When I enable the PrettyPhoto, it just gets placed under the WC lightbox.

    (I prefer how the WC lightbox looks, but when you view an image with it from an iPhone, it makes the image small and useless in iOS6 — cannot zoom! It's even smaller than the actual image on the product page.)

  6. daemonicus
    Member
    Posted 1 year ago #

    I have the same problem :( , "Enable WooCommerce lightbox on the product page" is checked, but is not working

    http://xn--blumediseo-19a.com/?product=hoja-de-balazo-plata-ley-925-con-cintas-de-agua-perla-cultivada-blanca

    please, somebody can help me? thanks in advance ;)

    also I dont have money to purchase something from Woo to post in their forums :(

  7. beastsyndicate
    Member
    Posted 1 year ago #

    Same problem.

    And I prefer the Pretty Box version even on a regular computer, and good to know about on a phone.

  8. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @beast - if you need help, starting a new thread is the best way to make that happen. Posting in old threads is not likely to get assistance, and it's unlikely that you have the identical problem as the OP.

  9. Caleb OLoan
    Member
    Posted 1 year ago #

    If anyone is interested I have found a way to get lightbox to appear on Woocommerce - though making use of another plugin.

    1] Install WP jQuery Lightbox 1.3.4.2
    2] Go to the file woocommerce/templates/single-product/product-image.php and change rel="thumbnails" to rel="lightbox"

    Lightbox plus then gives you loads of options for styling

    Notes

    1] If you want to do the editing from the WordPress admin side the file won't appear at first. So first click on woocommerce/templates/single-product.php then the relevant one will be on the page.

    2] This lightbox magnifies the image to its full size, that's fine for me, but you might want a lightbox that has a max size. Hopefully another plugin would do the trick.

  10. Caleb OLoan
    Member
    Posted 1 year ago #


  11. IamKirsch
    Member
    Posted 1 year ago #

    I couldn't get the WP jQuery Lightbox method to work. I installed the dynamic gallery and it messed something to where I can't get lightbox to work again.

  12. ehong33234
    Member
    Posted 1 year ago #

    works fine for me using latest wooframework 5.5.5 and mystile 1.2.6.

  13. Annekee
    Member
    Posted 1 year ago #

    I have wooframework 5.5.5 and mystile 1.2.7 and I am having the same problem, but the other way around: I don't want to open in Lightbox (w. the rounded corners), but whatever I check it persists opening in Lightbox. I even changed it to 'no' in the database but that doesn't help either.

    I have the same problem with the option of the product thumbnail aligned 'right' - it keeps aligning left.

  14. josh9787
    Member
    Posted 1 year ago #

    Did anyone find a solution to this.
    my new website [link removed] is having the same issue in woocommerce products.
    the theme i am using is White Light.

    I have contacted woo support, but no replys yet.

  15. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @josh9787 - please start your own thread on the WooCommerce forum here:

    http://wordpress.org/support/plugin/woocommerce

    Old threads aren't a good place to get help.

    You also really need to read this:
    http://codex.wordpress.org/Forum_Welcome#Warn_About_Adult_Content

    And mark your threads accordingly.

Topic Closed

This topic has been closed to new replies.

About this Topic