WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Woocommerce Image Size- unable to control (8 posts)

  1. emurph42
    Member
    Posted 1 year ago #

    Want to control my image sizes. Help is much appreciated - I tried everything I could find in past forum threads.

    My settings in Woocommerce-->Catalog-->Image Settings are:
    Catalog images W 150 H 100 (Hard crop selected)
    Single product image W 150 H 100 (Hard crop selected)
    Product thumbnails W 75 H 50 (Hard crop selected)

    But to no avail - my single product images are about 300x200 and catalog images are about 190x130.
    I inserted this into the wp-admin custom CSS area:

    ul.products li.product a img { width: 150; height: 100; }
    
    .related ul.products li.product img, .related ul li.product img, .upsells.products ul.products li.product img, .upsells.products ul li.product img { width: 150; height: 100; }
    
    .single-product.layout-full .images img {
    width: 150px; height: 100;
    }
    
    .single-product.layout-full .summary { width:600px; }

    It doesn't seem to be working. I also tried this fix in the woocommerce/assets/css folder, changing the 48% to 24%. It had no effect either.

    Check your CSS...It is blurry because of this ->
    .related ul.products li.product, .related ul li.product, .upsells.products ul.products li.product, .upsells.products ul li.product

    It is setting it to 48% width which in turns stretches out your 150x150 image...

    http://wordpress.org/extend/plugins/woocommerce/

  2. Yojance
    Member
    Posted 1 year ago #

    Try installing one of those plug-ins which regenerate your thumbnails. Your theme might be serving the only images it has so re-sizing them might help.

  3. emurph42
    Member
    Posted 1 year ago #

    Hi Yojance,

    I tried this but it has not made a difference. I think I need to change something in the CSS, but I don't know where the sizing problem is.

  4. bbernstone
    Member
    Posted 1 year ago #

    oy!! i found the mistake made by woocommerce.. you cant even change it unless you get yourself ftp access to the woocommerce.css file (in wp-content/plugins/woocommerce/assets/css) .. in there (if you make it cleaned up by going to http://procssor.com/) you will find a line (do a search for "img") that has width: 100%.. change this 100% to auto and you are all set!!

  5. jacquelinegleason
    Member
    Posted 8 months ago #

    Wait, how do you get to the woocommerce.css file? This is totally my issue that's been driving me crazy. FTP access to where?

  6. Colin Young
    Member
    Posted 8 months ago #

    Just FTP to your website, probably go to public_html then you should see the path that bbernstone gave you

    wp-content/plugins/woocommerce/assets/css

    Just be caredul when updating the plugin though because you might lose whatever you put in there

  7. jacquelinegleason
    Member
    Posted 8 months ago #

    ARE YOU KIDDING ME!? This SO worked. Thank you. Thank you. Very much appreciated.

  8. ucarman2002
    Member
    Posted 8 months ago #

    hello
    am having same problem with woocommerce images. can someone please tell me which css file to edit. wp-content/plugins/woocommerce/assets/css/?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic