WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Woocommerce https: pages not loading properly (22 posts)

  1. underwearnation
    Member
    Posted 8 months ago #

    I am running my site Underwear Nation using WordPress and the Woocommerce shopping cart version 2.0.20.

    I have installed W3 Total Cache version 0.9.3 to improve my website speed and I am having problems when the plugin is activated. All of my pages with https:// are not loading properly. It looks like the CSS is non-existent.

    I have followed the instructions to exclude the following pages from the cache through their respective settings panels:

    • Cart
    • My Account
    • Change Password
    • Edit Address
    • View Order
    • Checkout
    • Pay
    • Order Received

    But all of these pages are still the ones that are not loading properly. Does anyone have any ideas what might be going on?

    http://wordpress.org/plugins/w3-total-cache/

  2. binaryestate
    Member
    Posted 8 months ago #

    I had this issue with a few of my plugins when I activated JS minification. If you have JS minification, or even css minification for that matter, active under the Minify menu I would deactivate it and then clear all caches and see if those pages become active again. If it does work you can reactivate the JS/CSS minify but use your panel, usually cPanel, and go to your wordpress plugin directory (should be wp-content then plugins) and add the directory for the woo commerce, and any other plugin you are having trouble with, to the exclusions box under the Minify settings is W3 total cache. For example; if your site is underwearnation.com it would look like http// or http://www.underwearnation.com/wp-content/plugins/woocommerce to the exclusions box. I am not sure how woocommerce shows up in the plugins directory as I dont have it installed. You may have to actually find all of the directories that have .css and .js files in woocommerce and add those directories as well with a wildcard.extension after. For example: http://underwearnation.com/wp-content/plugins/woocommernce/*.css
    and
    http://underwearnation.com/wp-content/plugins/woocommernce/*.js

    ..please let me know if that helps!

  3. underwearnation
    Member
    Posted 8 months ago #

    I disabled all minification and cleared all caches and I am still having the same problem. That doesn't look like it solved it.

  4. binaryestate
    Member
    Posted 8 months ago #

    Is your site connected to cloudfare, or similar service? Is your woocommerce database hosted on the same server as your website or is it get the product info and such from another server somewhere else?

    You can try clearing all caches again, then deactivating the plugin, followed by a uninstall of w3tc. Before you reinstall delete the w3tc-config folder on your server if its still there as if its left all of your same settings will come back one your reinstall w3tc and the php script for w3tc in that folder may still be somehow affecting your .htaccess file even though the plugin is disabled. I would then turn on each feature, especially the minify features, one-by-one and check Woo functionality.

  5. binaryestate
    Member
    Posted 8 months ago #

    ...the w3tc-config folder is in your plugins directory

  6. underwearnation
    Member
    Posted 8 months ago #

    Yes I do have my site connected to Cloudflare. And my woocommerce database is hosted on the same server as my website.

  7. binaryestate
    Member
    Posted 8 months ago #

    If you have minification enabled for your site through Cloudfare have you tried turing it off, clearing cloudfare and local cache, and then seeing if Woo works?

  8. underwearnation
    Member
    Posted 8 months ago #

    I will do that! How do I clear my local cache? BTW thank you for all your help with this. I really appreciate it.

  9. binaryestate
    Member
    Posted 8 months ago #

    No problem at all. I had a very frustrating experience with w3tc, it is an awesome plugin, because it has many features. I still run into minification issues sometimes myself, then a rub my head until i have no scalp left until i figure it out. Clearing your local browser cache depends on your browse but for mist it will be under content in the settings menu. For IE and firefox i believe its under privacy. For Chrome its under settings and history. Also clear the cache on your server through w3tc. The best sequence is w3tc cache, then server cache, then browser cache so you know you are looking at the most recent everything.

  10. binaryestate
    Member
    Posted 8 months ago #

    ...for w3tc make sure to use the clear all caches option as if you hit the regular clear cache button I believe it only clears the page cache and the minifcation cache is likely what causing the problem. w3tc has to be active for you to clear the cache and then you can deactivate it...if this doesn't help Ill do some experimenting to see if we can figure this out as w3tc is very beneficial so getting it to work would be awesome.

  11. binaryestate
    Member
    Posted 8 months ago #

    ...for w3tc make sure to use the clear all caches option as if you hit the regular clear cache button I believe it only clears the page cache and the minifcation cache is likely what causing the problem. w3tc has to be active for you to clear the cache and then you can deactivate it...if this doesn't help Ill do some experimenting to see if we can figure this out as w3tc is very beneficial so getting it to work would be awesome.

  12. binaryestate
    Member
    Posted 8 months ago #

    you can actually set w3tc to not cache the Admin role I believe under general settings or page cache settings

  13. underwearnation
    Member
    Posted 8 months ago #

    And what benefit would not caching the Admin role have?

  14. binaryestate
    Member
    Posted 8 months ago #

    I haven't visited your site but unless everything on your site pulls from the Woo database , such as item description, turning off caching for the Admin you can see if a plugin you just installed, change you just made, Etc. messed up anything of your site rather than having to manually delete cache or waiting for the auto clear of cache to make sure everything looks good

  15. binaryestate
    Member
    Posted 8 months ago #

    ...bear in mind though that doing that increases your server hit slightly.

  16. underwearnation
    Member
    Posted 8 months ago #

    Okay I reinstalled the W3 Total Cache and activated it. The https:// pages were loading properly.

    Then the first thing I did was enable the CDN (MaxCDN). Then I clicked save settings.

    I then went to the CDN settings and put in my Authorization Key, selected my Pull Zone and filled in the "Replace Site's Hostname With" field. I clicked save.

    Now my https:// pages are not loading properly.

  17. underwearnation
    Member
    Posted 8 months ago #

    When I disable CDN and click save in the General Settings the https:// pages load properly.

    It must have something to do with the SSL settings. Unfortunately, every combination of SSL settings does not seem to improve the situation.

  18. binaryestate
    Member
    Posted 8 months ago #

    I believe Cloudfare as well as w3tc have options for use with SSL and the standard set up will cause issues as the CDN can't read your data correctly

  19. binaryestate
    Member
    Posted 8 months ago #

    I am not familiar with MaxCDN but have you checked to see if their system needs your SSL certificate on file in order to deliver your data?

  20. binaryestate
    Member
    Posted 8 months ago #

    I am not familiar with MaxCDN but have you checked to see if their system needs your SSL certificate on file in order to deliver your data?

  21. underwearnation
    Member
    Posted 8 months ago #

    Yes, I used the MaxCDN live chat and was able to resolve the issue. One of the SSL settings was incorrect on my account at MaxCDN and now everything is working properly! Thanks for all your help on this. Much appreciated.

  22. binaryestate
    Member
    Posted 8 months ago #

    That's great to hear, you are most welcome!

Reply

You must log in to post.

About this Plugin

About this Topic