WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
WooCommerce checkout form freezes while compiling billing address fields (6 posts)

  1. mompracem
    Member
    Posted 1 year ago #

    For some reason, during checkout in WooCommerce, right after the customer has entered a billing address (address, city, state fields...), the "checkout totals" form becomes greyed out with an ajax spinner (two WC dots spinning) and gets stuck there. I haven't figured out why this is happening. From the console I don't notice any javascript warning. I guess the checkout totals are triggered to update by the fields filling event - ie if the price totals are supposed to update based on address I suppose, even if there's no shipping in my setup and the product are marked as "virtual"... For some reason though the checkout totals form gets stuck and one can't submit the order.

    I've read of people experiencing the same issue. Some blamed HTTPS, but I'm not using SSL. Others mentioned plugins, but the problem still occurs if I disable them. Others say the WooCommerce pages must be there and have the proper shortcodes on them, but in my case I've left everything as is and double checked.

    While it's possible that what is causing the error could be in my theme and I will investigate further, I wonder if any of you had the same issue and how you solved it.

    I'm using the latest stable version of WordPress and WooCommerce.

    http://wordpress.org/extend/plugins/woocommerce/

  2. mompracem
    Member
    Posted 1 year ago #

    I'm not sure if it's relevant, but all my products are virtual (not downloadable) and I have set free shipping as default and only shipping option... Shipping has been disabled altogether in WooCommerce settings, same for Tax....

  3. makszbogar
    Member
    Posted 1 year ago #

    The same is in my shop avilera dot com. I didn't realize that, until one "not logged in" user tried to make purchase. If I am logged in wordpress and I try to do the same, everything starts to work. As soon as I log out, on checkout form (bottom part), I can watch for spinning dots hours and hours. Strange... I googled all about this issue and so far haven't found anything. I don't use ssl and i don't have this option enabled in my woocommerce settings. I purchased Custom Comunity pro theme and use it on this website. If anyone can help I would be verry happy too :).

  4. mompracem
    Member
    Posted 1 year ago #

    in my case doesn't matter if one is logged in or not, but what you described sounds the same

    things to rule out: plugins, wordpress url, ssl, woocommerce pages and their permalinks

  5. makszbogar
    Member
    Posted 1 year ago #

    I found out that my problem with spinning dots on checkout page was caused by plugin Under Construction. Plugin was loaded when there was no admin logged in, so this was the reason that checkout page worked fine when I was logged in and it didn't work when I was not logged in.

    Mompracem, thank you for you suggestion which made me go disabling every plugin step by step and I hope, you will find the reason for this unwanted checkout spinning situation, soon too.

    Http://avilera.com works for guests now too.

  6. Ultimate Peter
    Member
    Posted 5 months ago #

    Hello, I just researched this problem for two days and am trying to pass on my solution, because it was super frustrating:

    After entering City, State, Zip: Ajax spinner would spin indefinitely, even with no payment gateways, only cheque!
    Only for people not logged in to site. Worked fine for me logged in.
    Also, cart widget wouldn't display products.

    I followed every piece of advice I could find and the following didn't work:
    -Disable all plugins except woocommerce. (including fedex and payment gateway)
    -Disabled Ajax add button
    -Tried other themes, same thing
    -Checked all page names, shortcodes, and made sure they were appropriate parent/child.
    -Increased memory to WP and PHP to 128mb.
    -I didn't un-force https at checkout... Um, because that's crazy.
    -Turned off all shipping and tax.
    -Made sure my Site URL and Home URL were matching on the WP General Settings.

    So... MY BIG FIX WAS:
    I had WP All-in-one Security plugin installed...
    Now, even though I had it disabled:
    It had left behind some code in my .htaccess file.
    I don't know how I even came across it (while I was looking for some other config file I think). So, I got rid of the code in there for some of the security stuff and it worked again!

    Later,
    Peter
    http://qbservices.net

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic