WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] WooCommerce and Variable product / Variations problem (8 posts)

  1. Kurnik
    Member
    Posted 8 months ago #

    Hello all experts :)

    So I was reading quite a lot this forum regarding the same issue that I have but without any luck. So here I go, too...

    WP 3.8 with Woocommerce 2.0.20 all 22 plugins on or off doesn't matter.
    Running on child theme without any other problem.

    - Made Attributes
    - Add new product
    - Select Product data: "Variable product"
    - Add Attributes with no problem
    - Save
    - Click on Variations
    - Want to add new product but button "Add Variation" is dead! Nothing. Nada!
    The same story on "Link all Variations" button.

    WooCommerce Status Report all green:

    WC Version: 2.0.20
    WC Database Version: 2.0.20
    WP Version: WP 3.8
    Web Server Info: Apache
    PHP Version: 5.3.28
    MySQL Version: 5.5.34
    WP Memory Limit: 256 MB
    WP Debug Mode: No
    WP Max Upload Size: 64 MB
    PHP Post Max Size: 64 MB
    PHP Time Limit: 0
    WC Logging: Log directory is writable.
    Default Timezone: Default timezone is UTC
    fsockopen/cURL: Your server has fsockopen and cURL enabled.
    SOAP Client: Your server has the SOAP Client class enabled.
    WP Remote Post: wp_remote_post() was successful - PayPal IPN is working.

    I really need some expert to help me out. I have no other idea what to do or what to report for as much information as possible.

    Thanks in advance!

    http://wordpress.org/plugins/woocommerce/

  2. varktech.com
    Member
    Posted 8 months ago #

    Hi,
    Have you tried all plugins off except Woo, change theme to 2012, flush the theme cache + test?

  3. Kurnik
    Member
    Posted 8 months ago #

    Hey,

    No I didn't do all that. I want to use my theme and I also believe that woo commerce works on fresh installation with WP only. I have installed the same combination days ago for testing and it works. So I believe that with your suggestion everything, no not everything, but woo commerce and WP will and they work just fine.
    Like I said. I have similar combination already installed and successfully tried. Difference now is that I have child theme installed and like I say it's not problem in the plugins. I have disabled all but no champagne.

    Is there any terminal or something to check out what is going on behind the screen or something? How to find what is wrong except reading the code what I don't understand to read?

    Thanks for your advise!

  4. LogoLogics
    Member
    Posted 8 months ago #

    Hi Kurnik,

    I am not an expert but maybe this helps.
    If these "add variations" and " Link all variations" dont work, and you deactivates all plugins except Woo itself and it still doesnt work, it is a good thing to sort out what causes this.

    I hear you are using a child theme, so I suspect you did make changes in code? In my experience, some costum code can trigger this as well. To rule that at, try activating your parent theme and see if these buttons work then. If see, remove all custom code ( style css and functions.php and see if it works with child theme but without any costum code, if yes add costum code one by one to see if and when this problems starts again.

    Doing this helps you to identify the cause. Then leave that code out or ask the one that gave you this code what can be done to fix this. It is possible that some code worked fine some time ago, but is no longer compatible with new version of WP, Woo or some other plugin or theme.

    Good luck!
    Annie

  5. Kurnik
    Member
    Posted 8 months ago #

    Dear Annie,
    thank you for your explanation. It makes me think and yes I did activate main theme and there was the same problem. I don't know what to do now and I'm really bad in programming so I will try to install all things again and make more attention what, where and when will goes wrong.

    Thank you again for your time and answers!

  6. LogoLogics
    Member
    Posted 8 months ago #

    Hi Kurnik,

    You're welcome!

    I am currently using Woocommerce i.c.m. Canvas theme and dont have the issues your are talking about.

    May I ask which theme you are using and is that updated as well?
    When you activate your parent, are you sure you did not make any costumazations there by any chance? In functions.php or some extention plugin?

    If you change theme to lets say twenty eleven is the problem still there then?

    Annie

  7. Kurnik
    Member
    Posted 8 months ago #

    Annie,

    just to say I found a problem. It was in one of the plugins - I don't know how I miss that when I was, and I was, deactivated all of them.

    I'm happy again, hehe :D

    I'm using Elegant Themes but they are fine like Woo Commerce as well. The problem was / is in Social Panel plug in.

    http://codecanyon.net/item/social-panel-for-wordpress/4076940/comments

    Sorry to bother and THANK YOU again!

    ;)

  8. LogoLogics
    Member
    Posted 8 months ago #

    Hi Krunik,

    Glad to hear its solved and you are happy again haha.
    I use Elegant Themes for some clients too.

    If I use Woocommerce however, I prefer a Woocommerce theme, aspecially the Canvas theme, very costumizable and easy.

    Most of all its is 100% compatible with Woocommerce ( same developers ).

    Have a nice day,
    Annie

Reply

You must log in to post.

About this Plugin

About this Topic