WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
woocommerce add to cart does not show up (7 posts)

  1. Questions01
    Member
    Posted 1 year ago #

    I have set up a Product with three variations.
    When I go to the live page, and select one of the variations, the 'Add to Cart' button (+ # of items, etc.) doesn't show up.

    View here:
    http://goldeneagle.wallarootest.com/product/throttles/

    I came across a discussion of the same prob on this forum:
    https://github.com/woothemes/woocommerce/issues/1514

    Any ideas??

    Thanks.

  2. Roy Ho
    Member
    Posted 1 year ago #

    Switch your theme to 2012 and see if it works...

  3. Questions01
    Member
    Posted 1 year ago #

    I appreciate your reply.
    It might work, but we really want to stick with "Central theme" instead of 2012 theme.
    Would you give me any idea to solve this problem?

  4. Roy Ho
    Member
    Posted 1 year ago #

    You misunderstood. I didn't ask you to switch to 2012 and use that theme. I ask for you to test that theme so we know if it is indeed your theme causing the issue. It was only for a test.

    So now that we know it is your theme issue. Is your theme made for WooCommerce? And if so, does it support WC 2.0+?

  5. Questions01
    Member
    Posted 1 year ago #

    I tested 2012 theme and it worked.
    No, the "Central theme" is not made for WooCommerce.
    Would you give me any idea to solve this problem on my current theme?

  6. Roy Ho
    Member
    Posted 1 year ago #

    Every theme is different and there is no way for me to know what is wrong with your setup. I am merely trying to help figure out what is causing it which is a step towards fixing your issue.

    If you look inside your theme folder, do you see a sub-folder named woocommerce?

  7. Roy Ho
    Member
    Posted 1 year ago #

    If there is no sub-folder named woocommerce, follow the steps here -> http://docs.woothemes.com/document/third-party-custom-theme-compatibility/

    If there is, then copy that folder out to a safe place, delete it from your theme folder. Re-test. Dont' worry about if the design/layout looks off, just see if the function is working...

    If it now works with your theme, then that means the template files inside the woocommerce folder is out of date and most likely are pre 2.0 files which you need to update from the current woocommerce template files.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.