WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Woocomerce plugin (13 posts)

  1. Novellis
    Member
    Posted 1 year ago #

    Hi

    How do I get WooCommerce up and running so I can complete setting up my website? I have spent the whole week trying to resolve this issue and each tine there is a message: Your theme does not declare WooCommerce support, if you encounter layout issues please read our integration guide or choose a WooCommerce theme.
    I have tried WooCommerce 1.6.6 2.0.1 and 2.0.2.

    Help

    http://wordpress.org/extend/plugins/woocommerce/

  2. Roy Ho
    Member
    Posted 1 year ago #

    Don't worry about that message. It's just a message...As long as your frontend works and functions properly, that's all you need.

  3. Novellis
    Member
    Posted 1 year ago #

    This is a copy of mwssage, Your theme does not declare WooCommerce support, if you encounter layout issues please read our integration guide or choose a WooCommerce theme. My Theme dose not show as it's should, no navigator bars, I got to worry as I have paid for it that not what I expected. Every time spent trying to get my site up and running I am losing.

  4. Roy Ho
    Member
    Posted 1 year ago #

    You need to have a theme that is 2.0 compatible. From my message above, I am just telling you to ignore that message as it doesn't mean anything. Even a 2.0 compatible theme could have that message. So I was telling you as long as it works, then it works...

  5. solidgoldextra
    Member
    Posted 1 year ago #

    @Novellis: I feel you. I am experiencing same problem on a client's website. I will let everyone know how I get on.

    @splashingpixels.com: thanks for the tip, but I think we should be worried. An error message means something afterall.

  6. crdunst
    Member
    Posted 1 year ago #

    Take a look at this - you need to declare support for WooCommerce, maybe this would solve your problem:

    http://docs.woothemes.com/document/declare-woocommerce-support-in-third-party-theme/

  7. Roy Ho
    Member
    Posted 1 year ago #

    @solidgoldextra - no that is NOT an error message...It just just some text...Look into the code and see how it is generated if you have doubts.

  8. solidgoldextra
    Member
    Posted 1 year ago #

    @splashingpixels.com - thanks again. but I think the message is a warning about theme incompatibility with woo-commerce. Some clients have noticed that page layout has been affected whenever this message was seen. In my opinion, it is a heads up that there's a potential problem. Maybe not a stop error, but definitely important, if it affects someone's business. To say the message does not mean anything is not very helpful, to be honest.

    @crdunst - thanks, I've taken a look at the page, and I'll try to implement their recommendations from there. I'll report back here with my findings.

    I find it strange that the theme in use is a Woo-Commerce theme.

  9. Roy Ho
    Member
    Posted 1 year ago #

    @solidgoldextra - no that is not true...that message does not affect anything and does not check for theme compatibility. Whether that message is there or not has no bearing on if your theme works with 2.0+ or not. Please don't inflate this and scare people...People could have a perfectly working theme and still show that message and because of that, they think they need to find a fix...which is not necessary...

    And please read the OP message...he/she was not claiming anything was wrong...they are just saying there is a message...and my response was don't worry about it if everything is working...So there is nothing wrong with that response and IT IS helpful...

    And to give you an example, you can simply add this ->

    add_theme_support( 'woocommerce' );

    And that will make that message go away...So now does that mean just by adding that line, my theme will be compatible? Absolutely not...So what does that tell you? That message is irrelevant in this context and is only there so that theme developers are explicitly declaring support for WooCommerce, nothing more.

  10. Novellis
    Member
    Posted 1 year ago #

    Thanks, you all for kind help.I am not a developer so any suggestion to help me is appreciated. However for me to add any info I need a guided line how to do so. I'm not a website developer a creative fashion designer I can follow instruction.

  11. Roy Ho
    Member
    Posted 1 year ago #

  12. solidgoldextra
    Member
    Posted 1 year ago #

    @splashingpixels.com - thanks for clarifying things, although, I came here to seek help, not spread alarm. I'm not sure how using uppercase words at me, as you did earlier, helps. But ok. I accept what you're saying, and I'm not here to cause problems, just to get help.

    Please here is a quote from the developers themselves (Woo):

    For the most part, WooCommerce templates will integrate nicely with most WordPress themes. Where you may run into problems is when the default WooCommerce content wrappers do not match your chosen themes. This will manifest itself by breaking your layout on WooCommerce pages and shifting your sidebars into incorrect positions.

    This problem can potentially affect the shop page, the single product page and the taxonomy pages (categories and tags) because WooCommerce uses templates of its own to display these pages (and its impossible for WooCommerce to know exactly what markup your theme uses)

    I got that quote from this url:

    http://docs.woothemes.com/document/third-party-custom-theme-compatibility/

    This URL describes the problem, as well as offers their recommendations. So you see, I wasn't just making things up to "scare people", as you say.

    @Novellis - If you have purchased a premium theme, you would be better off contacting Woo support before making any changes. If you are working with a free theme, please consider the link I presented above, in addition to the other advise you have received from everyone here.

    In case you don't have a developer to help, take a look the Woo recommendations at the bottom of the page I have linked to:

    If all else fails…
    If you cannot work out the above methods, and don’t have access to a developer, we strongly recommend looking at our WooCommerce Themes which work out of the box as a hassle free solution.

    This is their own words, not mine. What I consider strange is that my client was using a WooCommerce Theme. I'm not sure what that says about the developers and their products. I'm all for quick fixes and so on, but for busy business people who are not developers (e.g. creative fashion designers), it can be a real problem when things don't work as they should after you've paid for them.

    Having said all that, I don't think Woo-Themes are supported by wordpress.org forum, anyway, so there.

    Thanks to everyone for their support and help.

  13. Roy Ho
    Member
    Posted 1 year ago #

    I understand you're trying to seek help but my comments was for the OP, not you...and what you quoted from that url has nothing to do with what we're talking about...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic