WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Woo-Commerce Update broke my checkout (33 posts)

  1. LSME
    Member
    Posted 5 months ago #

    Hello, I need urgent help. My woo-commerce was working just fine and then now I get an endless load on my checkout page at in the payment order form. I have searched hi and low on the web for an answer to this and I did everything you guys have as an answer with changing the wp memory (I have 256 per my server), I switched plugins off and on, I looked for errors but I can't figure it out. It was working just fine, woo-commerce needed an update I did so, and now this. Please help me with this I have an active site and I was about to buy a couple extensions from you guys but this has halted me two days; I know you guys require me to have purchased something for support but this is a very common thing as I can see and I am going to be a paying customer so can you please help me. Please tell me what I have to do, this was working fine, I am using the most up to date version of WP and my theme is the DYNAMIX theme.

    Thank you and I look forward to hearing back from you guys.

    https://wordpress.org/plugins/woocommerce/

  2. br4dy
    Member
    Posted 5 months ago #

    Having the exact same issue. Have tried all the usual debug things. Disabling all plugins, changing theme etc. But the AJAX loader just sits there thinking forever. If I inspect the object, and remove that div - can use the form fine.

    Was working fine on 2.1 - but stopped when upgrading to 2.1.3 (which is meant to have a fix for another AJAX problem, so would suspect that fix has broken this)

    Screenshot:

  3. RTownsend
    Member
    Posted 5 months ago #

    I'm having the exact same issue since the 2.1.3 update. Please share any responses!

    Many thanks!

  4. RichieP
    Member
    Posted 5 months ago #

    Same issue here, although mine went through to a page saying "sorry, the page does not exist"
    I thought it had trashed some pages but it still doesn't work.

    I'm using Sagepay Form plug-in and it had been working perfectly until this update.

  5. Julius123
    Member
    Posted 5 months ago #

    Have you guys checked the system status in your woocommerce menu for template overrides? I had the same issue, but it was just old templates. Once I deleted the templates my problem was solved. Hope it helps.

  6. LSME
    Member
    Posted 5 months ago #

    Theme
    Theme Name: DynamiX
    Theme Version: 4.0.1
    Author URL: http://themeva.com/
    Templates
    Template Overrides: No overrides present in theme.

    ^^ My System Status. It is not templates I believe. Everything works 100% fine except that form. As a matter of fact, due to some quick reflexes, if I load the page and click "Proceed to Paypal" to pay before the area is greyed out, I can checkout on paypal, my content is delivered, I get the money, the order is recorded etc. It is simply the fact that the form does not stop the greyed out endless load and it's really frustrating because I have a live site which makes daily sales.

  7. kayamm
    Member
    Posted 5 months ago #

    I have the same problem. These latest woocommerce updates are really bad..

  8. LSME
    Member
    Posted 5 months ago #

    Is there a way to revert back to the previous version without going to a backup of my site?

  9. RTownsend
    Member
    Posted 5 months ago #

    Strange...my site is working fine now, but i didn't make any changes whatsoever.

    Julius... I checked Woo system status and didn't have any old templates to delete.

    Strange, but i'm able to checkout now.

    My site: http://www.SaladDressingClub.com

    Thanks all,
    RT

  10. RichieP
    Member
    Posted 5 months ago #

    I made some progress but something else has happened.

    LSME you can download a previous version from here http://wordpress.org/plugins/woocommerce/developers/

    You need to FTP to your site and rename the woocommerce folder. The FTP this one up.

    I did this to the previous version but it still didn't work. I found out that it's something to do with the new Endpoints they are using. I had to go to the page I use for payment (one with [woocommerce-pay] on it) and change the end of the url to order-pay. The Endpoints are listed in the Settings pages.

    However, once I did this it worked. So, I thought I would try the upgrade again, but now I get the following error when i click "Place Order"

    {"result":"failure","messages":"

    \n\t\t\t
    Country<\/strong> is a required field.<\/li>\n\t\t\t
    First Name<\/strong> is a required field.<\/li>\n\t\t\t
    Last Name<\/strong> is a required field.<\/li>\n\t\t\t
    Address<\/strong> is a required field.<\/li>\n\t\t\t
    Town \/ City<\/strong> is a required field.<\/li>\n\t\t\t
    Postcode<\/strong> is a required field.<\/li>\n\t\t\t
    Email Address<\/strong> is a required field.<\/li>\n\t\t\t
    Phone<\/strong> is a required field.<\/li>\n\t\t\t
    You must accept our Terms & Conditions.<\/li>\n\t\t\t
    Invalid payment method.<\/li>\n\t<\/ul>","refresh":"false","reload":"false"}

    I read somewhere that someone fixed it by adding a payment or thank you page. I do have these, although I'm not sure if the upgrade has moved something again and they are not in the correct place.

    Does anyone have any idea about this?

    Url - http://www.ontheballtravel.com

    Thnaks

  11. artificial
    Member
    Posted 5 months ago #

    - RichieP

    Had exact same issue and found out it was the payment gateway that was the issue. Basically they never updated their api when the new woo came out. Still waiting on a fix from WorldNet.
    Hope this helps
    arti'

  12. creativeclicks
    Member
    Posted 5 months ago #

    This worked for me.

    I stopped WP loading a version of jQuery by placing this in my header

    <?php wp_deregister_script('jquery');wp_head(); ?>

    Perhaps there was a conflict between jQeury versions as Woo also loads jQuery into the page.

  13. LSME
    Member
    Posted 5 months ago #

    Including <?php wp_deregister_script('jquery');wp_head(); ?> did not work for me :/ there has to be a quick fix because this is killing me!

  14. randommess
    Member
    Posted 5 months ago #

    I rolled back to ver 2.1.1 for all files in this directory

    .../assets/js/frontend

  15. LSME
    Member
    Posted 5 months ago #

    Randommess did it work for you? If so can you post step by step instructions on how to do so..

  16. RichieP
    Member
    Posted 5 months ago #

    LSME I posted this above. It worked for me. I broke it again by trying another update:

    LSME you can download a previous version from here http://wordpress.org/plugins/woocommerce/developers/

    You need to FTP to your site and rename the woocommerce folder. The FTP this one up.

    I did this to the previous version but it still didn't work. I found out that it's something to do with the new Endpoints they are using. I had to go to the page I use for payment (one with [woocommerce-pay] on it) and change the end of the url to order-pay. The Endpoints are listed in the Settings pages.

  17. LSME
    Member
    Posted 5 months ago #

    I will like to confirm that I followed Randommess's advice and my checkout is now successfully working.

    Visit: http://wordpress.org/plugins/woocommerce/developers/ and download 2.1.2

    Connect via FTP and upload all files from 2.1.2 download in assets/js/frontend to your /wp-content/plugins/woocommerce/assets/js/frontend and override all the files there.

    It works for me perfectly now, I guess this is a temporary fix until we hear from the plugin authors.

    I am going to leave the topic as unresolved until others confirm that this worked for them.

  18. randommess
    Member
    Posted 5 months ago #

    Yes, LSME, this worked 100% for me. Go to your site using ftp and look in your plugins directory for woocommerce and then .../assets/js/frontend.

    I didn't check which one of the js files wasn't working correctly, instead I just rolled back that entire frontend directory. I didn't roll back my entire woocommerce install to the previous versions, just the directory.

  19. qualityeye
    Member
    Posted 5 months ago #

    The problem I'm having is that once you checkout and pay, you're sent to a 404 page. The credit card is charged, but instead of a Thank You page or receipt the customer gets a 404 error. I've tried downgrading to 2.1.2, that didn't work. I've tried turning off all plugins that didn't work. I've changed themes. I've increased the memory limit.

    I don't know what the problem could be. Has anyone experienced this error and know a fix?

  20. roozzak
    Member
    Posted 5 months ago #

    woocommerce 2.1.x has change the payment redirect url, make sure you change it too .

    http://wordpress.org/support/topic/plugin-woocommerce-212

  21. robmond
    Member
    Posted 5 months ago #

    Hi Guys Any updates on this as I' having the same problem..my cart is stuck on #shipping on the checkout.

    Any ideas would help.

    thanks

  22. qualityeye
    Member
    Posted 5 months ago #

    I fixed my problem. I did some more reading and it was because of not flushing permalinks after each plugin re-activation.

    The problem plugin was 0$ Woocommerce Product Feed from here http://www.victorciobanu.com/ .

    First I disabled every plugin. Then I activated them one by one. After I activated each plugin I went to Settings > Permalinks and hit Save. This was the key and the reason why I wasn't able to fix it earlier.

  23. RichieP
    Member
    Posted 4 months ago #

    I'm still having problems.

    I've tried overwriting the js files as above.

    I've even just tried WC 2.1.0 but I'm still getting the same error when I click "Place Order"

    Something is either missing in telling it what page to load with the [woocommerce_pay] shortcode on it or I'm missing the page somehow.

    Perhaps there's a clue in the url that loads when the error pages loads?

    http://www.ontheballtravel.com/wp-admin/admin-ajax.php?action=woocommerce_checkout&key=wc_order_53172a18d2ed6&order=1213

    Thnaks if anyone can help.

    I've had no response from the Sagepay Form Gateway developer about compatibility.

  24. qualityeye
    Member
    Posted 4 months ago #

    I tried looking for your my-account page and store but couldn't find it.

    The error you had in the beginning sounded like what happened to me. The page with the endpoints I used to figure out my issue was https://mysite.com/my-account/edit-address/billing/ this page and every other page with the new endpoints led to a 404 error page. I realized after paying for 13 transactions on my site that this was an easier way to fix the issue than just keep ordering from myself.

    Have you tried disabling all of your plugins except for woocommerce? Then refreshing permalinks. Then use the edit-address page to confirm if the endpoints are working. Then once you see the page is working, activate SagePay. Then refresh permalinks again. If that works you can keep re-activating all of your plugins refreshing permalinks with each one until you find the culprit(s).

  25. artificial
    Member
    Posted 4 months ago #

    New Version of Woo 2.1.4 out today seems to have fixed the issue with the jq conflict.. carts back working again..

  26. kayamm
    Member
    Posted 4 months ago #

    Its not working for me.. :(

  27. RichieP
    Member
    Posted 4 months ago #

    I can't believe what a mess this update seems to have made of people's websites.

    I also tried 2.1.4.

    I'm prepared to go back and start all over again. I guess I'll have an out of date version of WC but at least it will work.

    If I deactivate it through the Dashboard, then delete all the files, I assume the database will still have settings etc so when it's uploaded and activated again the settings will still be there and potentially wrong, as this is what seems to have happened when I try an older version now.

    How do I clear the database as well?

  28. woodson02
    Member
    Posted 4 months ago #

    I just had the same problem. 2.1.4 and 2.1.5 both had the icon just spinning. I followed randommess method and rolled back to 2.1.2 and my site is working again.

    Make sure you delete the entire frontend directory and then upload the 2.1.2 frontend directory. I tried doing it without deleting and the changes weren't working because I wasn't overriding the files in frontend because they weren't last modified.

  29. RichieP
    Member
    Posted 4 months ago #

    I'm going crazy.

    I removed all Woocommerce plugins and then uploaded an old version 1.6.

    Now it works again, although I get an error in the Dashboard "blockui requires jquery v1.2.3 or later"

    At least it doesn't affect the front end and I can work on this.

    After lots of research I think it's down to the Sagepay Form plugin not being compatible, and the (un)helpful developers at Patsatech are not responding to my requests for help.

    Cheers guys.

  30. achsanos
    Member
    Posted 4 months ago #

    My case: I usually disable the default wordpress jquery, and also the plugins default jquery enqueue scripts, so I can have more control about how each WP plugin is enqueued in each page and load for them just one jquery version - the latest. Right.

    I solve (?) this problem just updating the jquery version to latest version - remember, all my WP plugins use just it. So, I think the problem is because there's some jquery versions conflict, once some WP plugins, by default, call to a specific jquery version, not the most recent. Some sense?

Reply »

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.