WordPress.org

Ready to get started?Download WordPress

Forums

Simple Subscribe
[resolved] Won't send email error log (5 posts)

  1. ste_van
    Member
    Posted 5 months ago #

    I've tried to send a email to all my subscribers but it won't go. This is the error notification i get in the log:
    Unable to send email: Assigning the return value of new by reference is deprecated.

    https://wordpress.org/plugins/simple-subscribe/

  2. ste_van
    Member
    Posted 5 months ago #

    This only recently happened. I have not updated anything since last week when the last email was sent successfully. The only difference is that before there were under 30 subscribers, now there are more. If i deactivate a bunch, I am able to send out the email. I am using a genuine server email address.

  3. ste_van
    Member
    Posted 5 months ago #

    So I figured out that it's a problem with my server as they limit processes to send out a max of 25 emails at once. Perhaps including the option to restrict the number of email addresses per emails to a user defined amount as some other plugins do might be a good idea, unless there is another work around of which I am not aware.

  4. latorante
    Member
    Posted 5 months ago #

    Hi there mate,

    nice you sorted that out yourself! Seems unfair to me limit e-mail functions this way, but we some providers do this.

    I will think about that option in next releases.

    Kind regards,
    Mart

  5. ste_van
    Member
    Posted 5 months ago #

    That would be awesome if you allowed that option in the new update. I love the plugin, the fact that it sends the excerpt with the picture matches my theme perfectly. I can't find another plugin that does the same.
    But activating 25 subscribers, Publishing the post, then deactivating those 25, activating the next 25, update post as draft, republish post and repeat as necessary is too much work for me.
    Please update soon :)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.