WordPress.org

Ready to get started?Download WordPress

Forums

Google Analyticator
[resolved] Won't save any checkboxes - users to see dashboard widget (21 posts)

  1. Courtney Fantinato
    Member
    Posted 1 year ago #

    WP 3.5.1, version 6.4.2, and I got the following error when I tried to add other user roles to see the dashboard widget:

    Warning: stripslashes() expects parameter 1 to be string, array given in ..../wp-includes/kses.php on line 1257

    It won't save, and it also unchecks all checkboxes, including the ones under not to track. None of my choices are saved.

    I went back to 6.4.1 and it is now displaying the dashboard widget again and saving checkbox choices.

    Please fix!
    Thanks!

    http://wordpress.org/extend/plugins/google-analyticator/

  2. TH777
    Member
    Posted 1 year ago #

    UNDER ADMIN DASHBOARD WIDGETS
    I'm having the same issue, no error message it just won't save the Dashboard User roles that can see the Dashboard. So I don't see the dashboard.
    Thanks,

  3. gowp
    Member
    Posted 1 year ago #

    Same here. Non of the checkboxes keep selected when saving the settings. This does not only affect the dashboard widget selection but also the user groups to track.

    Restting the settings and authorizing again did not fix the problem. Only the dashboard widget appears for the first time after authorizing the plugin with Google Analytics. However, in this state the tracking is disabled. Once I change this and press "Save", all checkbox selections disappear.

  4. MinisitePro
    Member
    Posted 1 year ago #

    I'm getting the same problem. Unchecks all checkboxes

  5. gowp
    Member
    Posted 1 year ago #

    I had to remove any calls to wp_filter_kses between lines 310-325 in google-analyticator.php

    This got everything working again as expected. I'm not sure why wp_filter_kses is there in anyway, since the $_POST array already contains the required parameter arrays.

  6. mattcass
    Member
    Posted 1 year ago #

    Yep, and I'm getting a PHP warning on my site when trying to suppress tracking for logged in users (even though the checkboxes aren't saving on the admin panel).

  7. Webtaurus
    Member
    Posted 1 year ago #

    Same here, had to revert to older version.

  8. toto
    Member
    Posted 1 year ago #

    Exactly the same problem. Cant activate dashboard wedged???

  9. toto
    Member
    Posted 1 year ago #

    Temporaly HACK for fix to work.

    Open your DB, search for option name: ga_dashboard_role

    ADD this: a:2:{i:0;s:13:"administrator";i:1;s:6:"editor";}

    And you will get widged for Admin and eitor.

    Its a temporaly until plugin fix!!!

  10. J2000
    Member
    Posted 1 year ago #

    Where can I find an older version of the plugin? I need to have the Dashboard widget showing

  11. MacGuy42
    Member
    Posted 1 year ago #

    Same Problem with WP 3.4.1

  12. Courtney Fantinato
    Member
    Posted 1 year ago #

    @J2000 - Click on the "Developer" tab to download the previous version.

    It would be great if the author of the plugin could fix this ASAP!

  13. pawelsuder
    Member
    Posted 1 year ago #

    @J2000, Where exactly we should add the code in the Dashboard?

  14. andamira
    Member
    Posted 1 year ago #

    The same here. Just downgraded to 6.4.1 and the problem solved. Wont upgrade until this is fixed.

  15. J2000
    Member
    Posted 1 year ago #

    @Courtney Fantinato - Thanks!

    @pawelsuder - You don't enter code in the Dashboard. The plugin has an option to show a widget in the admin Dashboard (which doesn't seem to be working in the current version),

  16. davijg
    Member
    Posted 1 year ago #

    Thanks Toto that worked for me as a temp fix.

  17. tommls
    Member
    Posted 1 year ago #

    Please fix this ASAP!!
    Does anyone know what to put into the database to not have admin and editor user/logins tracked??
    I'm using this one instead of Yoast plugin *because* it has the dashboard...
    Tried to install older version still same problem...
    Thank you, Tom

  18. tommls
    Member
    Posted 1 year ago #

    Where can I find an older version of the plugin????

    Thank you, Tom

  19. Courtney Fantinato
    Member
    Posted 1 year ago #

    @tommis - Click on the "Developer" tab to download the previous version.

  20. Video User Manuals
    Member
    Plugin Author

    Posted 1 year ago #

    Hi all.

    Terribly sorry for the slow reply here. We've identified this bug and how released an update (6.4.3) - please let us know if you have any other issues.

  21. andamira
    Member
    Posted 1 year ago #

    Updated to 6.4.3 The issue is fixed thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic