WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Within site WP Installation Problem (9 posts)

  1. Alajazcom
    Member
    Posted 1 year ago #

    Hi.

    I am trying to install WP within my existing site http://www.alajaz.com.

    For separate installation I uploaded all WP files in an folder in my site root, i.e. "siteroot/WP folder" all went well during installation, but when I tried to excess my blog site i.e. "mysite/WP folder/", then instead of getting the WP page, I get my existing site main page. I tried several times but result is same every time, so I deleted the WP folder.

    Please let me know how to install WP within mysite without disturbing the existing site.

    Regards.
    Ajaz

  2. Jonathan Dingman
    Member
    Posted 1 year ago #

    You can install it in a directory. Although, I do recommend NOT using a folder that has a space in it, ie "not like this" but rather use a - like this, "like-this".

    Here are the docs on how to install it in a directory: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  3. Alajazcom
    Member
    Posted 1 year ago #

    I din"t used space in the actual folder.

    Anyway I followed the instructions in http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory and changed the General Settings

    In the box for WordPress address (URL): change the address to the new location of your main WordPress core files. Example: http://example.com/wordpress to (http://www.alajaz.com/blog/wordpress)
    In the box for Site address (URL): change the address to the root directory's URL. Example: http://example.com to (http://www.alajaz.com)

    Now I can't even login to admin panel.

    Check these out:

    1: http://www.alajaz.com/blog/wordpress/wp-admin/index.php

    2: http://www.alajaz.com/blog/wordpress/index.php

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory talks about htaccess file, but I can't find the htaccess file in WP files any where. The only htaccess files I see on me site are of the existing site.

    Kind regards

  4. knaveenchand
    Member
    Posted 1 year ago #

    1. Try to open your database tables using phpMyAdmin from your hosting control panel.
    2. Go to your latest database that you have created and then look into the table named wp_options
    3. Here you will find siteurl under option_name filed in the very first row.
    4. You can change its corresponding value in option_value to the site url of your choice.
    5. Open that url in a new browser and try. These are just some leads for you to get started.

  5. Alajazcom
    Member
    Posted 1 year ago #

    Great Changing the value in DB enabled me to go to admin panel, but still I can not access the wordpress site:

    http://alajaz.com/blog/wordpress/wp-admin/index.php (Now Working)

    http://www.alajaz.com/blog/wordpress/ (NOT WORKING)

    http://www.alajaz.com/blog/wordpress/index.php (Not WORKING)

  6. knaveenchand
    Member
    Posted 1 year ago #

    If you are able to login to dashboard, go to General Settings and ensure that the URLs in WordPress Address URL and Site URL are exactly the same.

    Try not to use www in your URLs. If it doesn't work, try prefixing www. Whatever you do, try to do it uniformly in both the fields.

  7. Alajazcom
    Member
    Posted 1 year ago #

    I am using these values, and as you can see both are same;
    WordPress Address (URL): http://alajaz.com/blog/wordpress
    Site Address (URL) : http://alajaz.com/blog/wordpress

  8. Alajazcom
    Member
    Posted 1 year ago #

    I have resolved the problem in this way.

    1: Created a subdomain.
    2: Installed WP on the subdomain.
    3: Edited .htaccess as follws;
    # Use PHP5 Single php.ini as default
    AddHandler application/x-httpd-php5s .php
    # BEGIN WordPress
    # END WordPress
    RewriteCond %{HTTP_HOST} ^alajaz.com$ [NC]
    RewriteRule (blog)(/.*|$) $1.alajaz.com/$2 [R=302,L]
    RewriteCond %{HTTP_HOST} ^blog.domain.com$ [NC]
    RewriteRule (.*) %1/$1 [L]

  9. Alajazcom
    Member
    Posted 1 year ago #

    Thanks for support

Topic Closed

This topic has been closed to new replies.

About this Topic