WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Within 2.8.4, published pages yielding a 404 error (3 posts)

  1. fssc
    Member
    Posted 4 years ago #

    After a fresh installation of WP 2.8.4 at http://spiritualdenver.com, I created pages for the menu bar. At first these worked great, but then i started getting a 404 error - pages not found on the server.

    E.g.
    http://spiritualdenver.com/classes/
    yield this error message:

    Not Found

    The requested URL /classes/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.2.8 Server at spiritualdenver.com Port 80

    I wonder if a clue might be in the reference to "FrontPage" -- which the site does not use, but I'm really unsure about this.

    Another clue is that the .htaccess file contains this code:

    # -FrontPage-

    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName spiritualdenver.com
    AuthUserFile /home/spiritua/public_html/_vti_pvt/service.pwd
    AuthGroupFile /home/spiritua/public_html/_vti_pvt/service.grp

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    DirectoryIndex index.html index.htm index.php

    FYI, Permalinks are set to a custom structure of "/%postname%/"

    So, that's as much as I know so far that may be relevant. Help please? I cannot build the rest of the site until i get this resolved.

  2. Kailash
    Member
    Posted 4 years ago #

    If you are not using FrontPage Extension, I suggest you to uninstall it from your cPanel. Also, make sure that your host has enable mod_rewrite Apache module.

  3. fssc
    Member
    Posted 4 years ago #

    SOLUTION FOUND!

    Turned out that most of the text in the .htaccess file related ro Frontpage, specifically,

    # -FrontPage-

    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName spiritualdenver.com
    AuthUserFile /home/spiritua/public_html/_vti_pvt/service.pwd

    Deleting all of this text from the .htaccess file instantly resolved the problem. I'm going to leave this item posted here on the forum for anyone else who runs into the same problem.

Topic Closed

This topic has been closed to new replies.

About this Topic