WordPress.org

Ready to get started?Download WordPress

Forums

Sabre
[with solution] Cannot install with MySQL 5.5 (2 posts)

  1. JiBee
    Member
    Posted 1 year ago #

    Hi,
    The plugin cannot be installed when using MySQL 5.5.

    The file classes/sabre_class.php, line 1250 to 1263 creates a table using the TYPE=MyISAM option, which is deprecated since MySQL 4.0 and no longer available since MySQL 5.5.

    The solution is to replace the TYPE=MyISAM with the correct stanza ENGINE=MyISAM (or drop altogether the engine specification).

    http://wordpress.org/extend/plugins/sabre/

  2. Josh Carr
    Member
    Posted 1 year ago #

    I took the liberty of updating a few things in the plugin including this error because I really wanted to use it and the developer seems to have disappeared. If he ever comes back, I'll be happy to remove my link:

    sabre-1.2.2.2.zip

    I've updated it a couple times for various things, so I just tacked another .2 onto the end of the version number.

    I've fixed the MySQL table creation error by removing the deprecated TYPE option.

    I've also fixed the DNS blacklist issues. The queries worked, but they would return false positives. I replaced zen.spamhaus.org with the two correct servers: sbl.spamhaus.org and xbl.spamhaus.org.

    I also updated the gethostbyname logic to prevent false positives. It will only show the banned ip error if one of the proper DNS blacklist servers recognizes the IP address.

    I don't have much time to maintain a plugin, but I did fix what wasn't working for me -- and what most people are complaining about on here. I cannot guarantee that I'll be able to fix any other issues as I seldom have time to visit the forums.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic