WordPress.org

Ready to get started?Download WordPress

Forums

WinXP and Permalinks (5 posts)

  1. SpaceRook
    Member
    Posted 10 years ago #

    Hello,
    I'm designing my WordPress site on WinXP before I upload it to my "real" host. I'm having trouble getting permalinks to work. I'm a newbie to Apache, but this is what I've tried based on the documentation:
    I change the settings in the Permalink Options using the sample string.
    In the Apache http.conf file, I changed the AllowOverride parameter:
    DocumentRoot "C:/web"
    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>
    In my C:\web directory, I put a .htaccess file with the parameters specified on the Permalinks page:
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^archives/([0-9]{4})?/?([0-9]{1,2})?/?([0-9]{1,2})?/?([0-9a-z-]+)?/?([0-9]+)?/?$ /wordpress/index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5 [QSA]
    RewriteRule ^archives/category/?(.*) /wordpress/index.php?category_name=$1 [QSA]
    I rebooted Apache. Now all my article links give 404's. I put an identical .htaccess file in c:\Web\wordpress, but that didn't work, either.
    Any help appreciated. Also, how will permalinks work when I go to a shared host? (Lunarpages)? What if my web host doesn't allow AllowOverride All?

  2. TechGnome
    Moderator
    Posted 10 years ago #

    Well, if they are on a (L)Unix server, you are probably OK. People (incl. myself) have been having trouble getting permalinks like that to work properly on Winders boxes. Supposedly there's a way around it, but I don't know what it is.
    TG

  3. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    You don't need AllowOverride All, just mod_rewrite configuration.

  4. orban
    Member
    Posted 10 years ago #

    SpaceRook:
    Change:
    1. AllowOverride None -> AllowOverride All
    2. Uncomment #LoadModule setenvif_module modules/mod_setenvif.so (remove the #)
    Restart Apache. It works. :)
    -orban

  5. SpaceRook
    Member
    Posted 10 years ago #

    Yay, I got it!
    It was a combination of uncommenting that line, putting the .htaccess file in the right place, and setting AllowOverride All in the RIGHT section (I didn't know there were multiple AllowOverrides. Hey, I told you I was an Apache newbie!).
    On the bright side, I learned a helluva lot about mod_rewrite. Now I just have to figure out how to get my images in /img to load.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.