WordPress.org

Ready to get started?Download WordPress

Forums

124

[resolved] Windows server infinite redirect after upgrading to 3.1 (99 posts)

  1. hereswhatidid
    Member
    Posted 3 years ago #

    I'm getting an infinite redirect loop after upgrading from 3 to 3.1. I'm running this on a Windows machine using the ISAPIRewrite module from Helicon. The permalinks were working fine prior to the upgrade and I've already tried resaving them via the admin and restarting IIS on the machine in case anything was being cached.

  2. krispy_b
    Member
    Posted 3 years ago #

    I'm getting same error on my site (windows 2003 server) - but I'm not using any extra modules for permalinks - it seems to be something 3.1 is doing under windows, even with 'standard' links.

  3. AardvarkGirl
    Member
    Posted 3 years ago #

    Me too. I won't post my ordeal (I have access to my server so I've tried a lot) but you can look up my posts.

    While I can get to the back end of my site, I can't get to the front end (IE just hangs, but FF and Chrome were nice enough to give me a redirect / loop error message).

  4. lordarkad
    Member
    Posted 3 years ago #

    Same here. I have a test server running on Windows Server and IIS 6 with standar permalinks, and I can't access the admin dashboard.
    I can see the frontend, though

  5. AardvarkGirl
    Member
    Posted 3 years ago #

    LOL - well I think I'd rather the front end show and seem ok. ;-) At least clients wouldn't be calling asking "Where is my website!"

    Seems like there are enough of us having an issue - wonder why someone from WordPress isn't saying something, or at least acknowledging?

  6. James Laws
    The WP Ninjas
    Posted 3 years ago #

    I'm having a similar problem. Tried a manual upgrade on an iis7 server and now I can login. The front end works fine but I have no access to admin.

    I can see there has been no consensus as to how to rectify this, has there?

  7. AardvarkGirl
    Member
    Posted 3 years ago #

    I've been posting since this morning. :-\

  8. krispy_b
    Member
    Posted 3 years ago #

    I agree AardvarkGirl - the front end would at least mean my visitors were seeing something while i wait for someone from the dev team to post

  9. swinks72
    Member
    Posted 3 years ago #

    Same here, but it concerns only the homepage. WP-Admin Backend is accessible.

  10. jarnez
    Member
    Posted 3 years ago #

    I'm having the same issue. I can access all pages except the homepage.

  11. keesiemeijer
    moderator
    Posted 3 years ago #

    Have you tried:
    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).
    - switching to the default theme to rule out any theme-specific problems?
    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?
    - Try re-saving your permalink structure or using the default structure at Settings/Permalinks in your admin panel. If WordPress cannot automatically edit the .htaccess file, it will provide manual instructions after saving.
    -renaming your .htaccess to test.htaccess

    For those who cannot log in:
    - resetting the plugins folder by using FTP or whatever file management application your host provides. Sometimes, an apparently inactive plugin can still cause problems.
    - switching to the default theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides.
    -renaming your .htaccess to test.htaccess

  12. krispy_b
    Member
    Posted 3 years ago #

    pretty much done all of that..

    did the reset plugins, set to default theme. went into the permalinks page and hit save (i'm using default structure anyway)

    remember we're saying it's on windows - so no .htaccess files to play with as they are unix/linux only.

  13. hereswhatidid
    Member
    Posted 3 years ago #

    I've gone through all those steps and it's still going into the infinite loop on permalinks that do not include /index.php/ at the beginning or are just using the /?p= format.

  14. jarnez
    Member
    Posted 3 years ago #

    I just installed this plugin:
    http://wordpress.org/extend/plugins/permalink-fix-disable-canonical-redirects-pack/

    And it seems to have fixed my issue. I can bring up all the site pages now.

  15. AardvarkGirl
    Member
    Posted 3 years ago #

    keesiemeijer

    Have you tried:
    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    Yup. Was able to deactivate them all in the admin. Someone suggested go change the plug in folder name - I not only tried it on FTP but actually remoted onto the server and it would not grant me access to change the plug in name (access denise, in use...).

    - switching to the default theme to rule out any theme-specific problems?

    That was the first thing I did. And to rule that out I ran the install on another wordpress site I have (a test that is a stock install - only a child theme and no plug ins) and it bombed as well.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    I did one better - I killed EVERYTHING and downloaded and unzipped a fresh 3.1 to my server and put the files on the directory by hand.

    Then on our WP test site we killed EVERYTHING including the database and did a 'from scratch' brand new install of 3.1 and had the same exact issues we had with the auto-updated site.

    - Try re-saving your permalink structure or using the default structure at Settings/Permalinks in your admin panel. If WordPress cannot automatically edit the .htaccess file, it will provide manual instructions after saving.
    -renaming your .htaccess to test.htaccess

    I'm on a windows machine.

  16. krispy_b
    Member
    Posted 3 years ago #

    I've tried to change the perm links structure through the admin page to see if that gives it a kick - no change.. so changed it back to standard
    /?p= format

    I can't believe this isn't a fundamental bug/flaw in the base code - maybe not been tested on windows servers enough?

    i hope someone in the dev team is taking note - every second that ticks by is lost visitors to my site.

    I guess I need to read up on going back a version.. I guess I can't get away with copying files in from 3.0.5 but leaving the db as is? (any db changes for 3.1?)

  17. jarnez
    Member
    Posted 3 years ago #

    Hi everyone,

    Try the plugin:
    http://wordpress.org/extend/plugins/permalink-fix-disable-canonical-redirects-pack/

    It worked for me. I'm now running 3.1 on our IIs server will all pages loading just fine.

  18. hereswhatidid
    Member
    Posted 3 years ago #

    I just tried that plugin linked by jarnez on my dev environment and that appears to get it working again. Perhaps this will clue the dev team in as to what might be causing this issue.

    http://wordpress.org/extend/plugins/permalink-fix-disable-canonical-redirects-pack/

  19. krispy_b
    Member
    Posted 3 years ago #

    jarnez - if I could kiss you I would!!

    That's fixed it for me - hopefully whatever that does, the devs can check what changed in v 3.1 and get a 'proper' fix into their code.

  20. jarnez
    Member
    Posted 3 years ago #

    Yea! I'm glad it worked for you! After I installed it, I wanted to kiss the plugin developer =)

  21. swinks72
    Member
    Posted 3 years ago #

  22. hereswhatidid
    Member
    Posted 3 years ago #

    So does this qualify as resolved or is there a "kinda resolved but not ideal" option?

  23. James Laws
    The WP Ninjas
    Posted 3 years ago #

    Well, since some of us can't even access our admin I guess not.

  24. Samuel Wood (Otto)
    Tech Ninja
    Posted 3 years ago #

    It might help if somebody that can reproduce this problem could provide a dump of their $_SERVER variable (when the problem is happening, obviously, not when you have a plugin fixing it).

    Feel free to sanitize out what you think might be sensitive information first.

  25. RockyMtnHi
    Member
    Posted 3 years ago #

    I can also log into the back-end but the main page is down on a Windows hosting.

    I did the following - switched themes, deactivated all plugins, re-uploaded the wp-admin and wp-includes files, changed permalink settings - still no workie.

    Hope this gets noticed because we're dead as a doornail now. Oh, and FYI, our blog is at http://www.mercuryleads.com/lead-generation-blog/.

  26. James Laws
    The WP Ninjas
    Posted 3 years ago #

    You mean something like this.

    [Code moderated as per the Forum Rules. Please use the pastebin]

  27. AardvarkGirl
    Member
    Posted 3 years ago #

    Otto

    I can reproduce it and give you what ever you want... just tell me how to give it to you.

    Just send me a detailed message and I'll give you what ever you want (I have full access to the server, but I'm not a server tech person, give me detailed instructions and I'll give you what ever you want).

  28. AardvarkGirl
    Member
    Posted 3 years ago #

    krispy_b

    I guess I need to read up on going back a version.. I guess I can't get away with copying files in from 3.0.5 but leaving the db as is? (any db changes for 3.1?)

    This did not work for me. At all.

    I then exported my tanked 3.1 upgrade database and imported it into a fresh 3.0.5 and it tanked that too.

    I finally went in and found the servers back-ups of our mysql databases and am in the process of doing a complete delete and fresh install of 3.0.5 with yesterdays database. :-(

    Of course now I'm having an issue deleting the plug in folder- the damn thing will not release one of the related captcha plug in files, says we can't access the file because it is in use (and I'm remotely logged into the server). ARG!!! DIE! DIE! DIE!

  29. RockyMtnHi
    Member
    Posted 3 years ago #

    jarnez,
    That did it for me also.
    Thanks a million...

  30. grvogt
    Member
    Posted 3 years ago #

    Thanks, Problem solved with the plugin provided above by jarnez. Well played.

124

Topic Closed

This topic has been closed to new replies.

About this Topic