WordPress.org

Ready to get started?Download WordPress

Forums

Windows localhosting question (4 posts)

  1. hooopla
    Member
    Posted 9 years ago #

    I'm using podz' "Moving your WordPress weblog inside your PC" tutorial. I believe I've followed the instructions exactly, but I'm having a problem.

    On my host, my site's URI is http://cuppanews.com.

    On my PC, I've installed XAMPP. In the htdocs folder, XAMPP installs a lot of stuff of its own, so I've created a subdir called c:apachefriendsxampphtdocscuppanews and put the downloaded copy of my WordPress install there.

    In the local copy of the SQL, I've replaced instances of http://cuppanews.com with http://localhost/cuppanews.

    Now, when I load http://localhost/cuppanews/index.php, I get the main page for my local site. But when I click on any of the category or archive links, I get a 404. For example, I have a category called "technology" and the 404 error says: The requested URL /cuppanews/category/technology/ was not found on this server.

    I have a feeling (dread, I think it's called) that I need to create an .htaccess file that does some voodoo for my local install. What do you think?

  2. binarymoon
    Member
    Posted 9 years ago #

    Permalinks didn't work when I tested things offline (I used easyphp - I assume it's similar to xampp. Remove all permalink settings on the options screen and delete the .htaccess file if there is one. That sorted everything for me.

  3. hooopla
    Member
    Posted 9 years ago #

    Excellent! Thank you, BinaryMoon! That's a great help.

  4. zywiec
    Member
    Posted 9 years ago #

    permalinks with xampp:

    locate the file httpd.conf, mine is at xampp\apache\conf\httpd.conf
    locate the line:
    #LoadModule rewrite_module modules/mod_rewrite.so
    remove the hash(#)

    tested using permalink setting of /%year%/%monthnum%/%day%/%postname%

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags