WordPress.org

Ready to get started?Download WordPress

Forums

Windows Live Writer issue and WordPress 2.6x (32 posts)

  1. bebo2good1
    Member
    Posted 5 years ago #

    Hi, Im having a problem, I use Windows Live Writer to Blog WordPress with the Latest version, I moved the Blog to my server, since it was at a free host working great but I moved to my domain, but now everytime I or the staff blogs, Instead of the Blog page showing a Proper blog, it then looks like HTML Blogged.

    Why is this happening?

    Here's a sample:

    http://ctfblog.ctforumgroup.com/?p=3

    I backed up my old posts, I reinstalled WP 3 times and im getting tired doing this..

    Please help me with this 0=)

    Thanks!

  2. bebo2good1
    Member
    Posted 5 years ago #

    An Updated URL:

    http://ctfblog.ctforumgroup.com/wordpress/?p=3

    please any1?

  3. iridiax
    Member
    Posted 5 years ago #

    Too high security settings at your web host could cause html tags to be stripped.

  4. bebo2good1
    Member
    Posted 5 years ago #

    so what do I do about this?

  5. iridiax
    Member
    Posted 5 years ago #

    Contact your web host.

  6. alykhan2
    Member
    Posted 5 years ago #

    I'm having the exact same problem with 2.6.2. I've tried it with Live Writer, ScribeFire and Ecto. Any pointers on the security settings?

  7. centepines
    Member
    Posted 5 years ago #

    Any feedback on this?
    I've contacted my webhost about it and they said that is not the problem.

    Hepl please?

  8. iridiax
    Member
    Posted 5 years ago #

    What does a sample of the code look like before posting and what does it look like after posting?

    I'm really no expert on server stuff, but if your web host is using something like mod_security, it may be preventing you from posting code. Are they using it?

    Also, do not use the visual editor if you are adding your own code and do not switch back and forth between the visual and html editors. Doing so will just mangle your code.

  9. centepines
    Member
    Posted 5 years ago #

    In my particular case, mod_security is not being used (just confirmed it with my host). I tried all ways, visual editor, source code (one at a time). Not working.
    Code looks fine in WLW at the time of posting, but when cheking on my blog, you can see all the HTML (sortof) like :

    strongThis is a sample sentence/strong
    pThis is another sentence/p
    Just like that

    Same Windows Live Writer is working fine with a test account I created on a Free Web Hosting site. But in my own site (new) there's no way :(

    It could be some CHMOD on some directory or something? (sorry, I'm just clueless and very frustrated :( )

  10. iridiax
    Member
    Posted 5 years ago #

    Try temporarily disabling all plugins and see if the problem continues.

  11. centepines
    Member
    Posted 5 years ago #

    Thanks for your reply,
    Done that too :( Also, changed templates, etc
    By the way, I just installed ScribeFire, and the same thing is happenning. Very strange.

  12. iridiax
    Member
    Posted 5 years ago #

    One other thing to try:

    Go to Dashboard -> Users -> Your Profile and then deselect Use the visual editor when writing.

  13. centepines
    Member
    Posted 5 years ago #

    Tried that too, no change. Been lurking Google, and found out some other people having the same issue, with other publishers to, like Blogjet.
    One of them said uninstalling Office 2007 did the trick, but I don't see any connection with that?

  14. centepines
    Member
    Posted 5 years ago #

    Any feedback on this or how can I fix it? :)

  15. Kimberly
    Member
    Posted 5 years ago #

    Hi

    I just found that is was libxml2-2.7.1-1.fc9 on my server that was causing the problem.

    I down-graded to 2-2.6.32-1.fc9 and I was able to publish with WLW again.

  16. davestarr
    Member
    Posted 5 years ago #

    kim-_nz, thanks for that tip. Where did you find that file on your server, and how does one go about downgrading? I have excatly the problem you are describing, I too thought at first it was WLW and thne also thought it was something specific to WP 2.6.2, because on several blogs that have not yet been upgraded to.6.2 the problem did not appear.

    For those who made a lot of helpful suggestion re. HTML and the Visual editor, this is a weird problem where WordPress displays _partial_ HTML instead of th desired human readble form. In other words, a paragraph which should read "This is my paragraph" and which of course in HTML shows "<p>This is my patagrah ... instead displays as " p>This is my paragraoh ... (note the leading '<' character is stripped of, breaking the code.

    It's been really, really frustrating the past few day sas every single blog post has to be hand edited, character by character in the HTML editor to put the borked code back into readable format.

  17. delutz
    Member
    Posted 5 years ago #

    I asked my host to downgrade libxml per kim_nz's suggestion, but the problem persisted even after the downgrade in my case. This is frustrating.

  18. Kimberly
    Member
    Posted 5 years ago #

    Hi.
    On my Fedora 9 I had to downgrade to libxml2-2.6.32-1.fc9 and xml-common-0.6.3-23.fc9.

    I initially started with a downgrade of PHP (I thought it may have been php's processing of xmlrpc.php) but still had the issue so I then downgraded libxml and xml-common and the problem was resolved.

    I then re installed the latest php from the update repo. I had to set up yum to exclude libxml* and xml-common* so the nightly yum update didn't put the libxml files back in place.

    I found it wasn't a WP issue when I setup a test blog site on my old Cobalt RaQ4i and had no problems publishing from WLW so I started looking into what packages were upgraded on my server around the time I upgraded WP to 2.6.2

    hth
    Kim

  19. bebo2good1
    Member
    Posted 5 years ago #

    @kim, i have cpanel, is there anything here that needs to be updated to get WLW working?

    http://www.image-plex.com/files/4ngfcohaikr9lgyobtmn.jpg

    Thats the pearl list versions

  20. Kimberly
    Member
    Posted 5 years ago #

    Hi bebo2good1

    AFAIK, perl modules shouldn't have any effect on WP. I could be wrong. I don't deal with perl much and haven't made any modifications to any perl libraries from what is installed by default.

  21. lexhair
    Member
    Posted 5 years ago #

    WordPress 2.6.x disables remote blogging by default. Go to options->writing and make sure XML-RPC blogging is checked.

  22. murph2481
    Member
    Posted 5 years ago #

    Does anyone have a solution for this issue? I am still having problems posting using WLW to WP 2.6.2 and I have tried everything above to no avail! Anything to do would be great because I can only blog with WLW because I hate using the interface and uploading pictures it is a huge pain!

    Thanks,
    Dan

  23. enlitener
    Member
    Posted 5 years ago #

    I had that same problem. I only resolved it by deleting any plugins that would imporve the basic WP TinyMce editor. Then WLW worked fine.

  24. homeofsport2008
    Member
    Posted 5 years ago #

    Try temporarily disabling all plugins and see if the problem continues.

    [ad link moderated. Resist the urge, thanks]

  25. murph2481
    Member
    Posted 5 years ago #

    Nope tried that with no luck, I tried disabling all plugins with no luck

  26. friedbeef
    Member
    Posted 5 years ago #

    For those who made a lot of helpful suggestion re. HTML and the Visual editor, this is a weird problem where WordPress displays _partial_ HTML instead of th desired human readble form. In other words, a paragraph which should read "This is my paragraph" and which of course in HTML shows "<p>This is my patagrah ... instead displays as " p>This is my paragraoh ... (note the leading '<' character is stripped of, breaking the code.

    I have this same exact problem, which is incredibly frustrating as well. WordPress.org folks - help!

  27. martinezgeovani
    Member
    Posted 5 years ago #

    if you post includes images here is the possible solution http://geovanimartinez.com/?p=44

  28. centepines
    Member
    Posted 5 years ago #

    Any news on this?

  29. monkeylove
    Member
    Posted 5 years ago #

    For HTML tags being stripped, write to your web host suppport and ask them to add the XMLRPC libraries or recompile Apache.

  30. Johanhorak
    Member
    Posted 5 years ago #

    Hi I am having this problem as well and have deactivated all plugins. I have asked my host to downgrade to libxml2-2.6.32-1.fc9 and xml-common-0.6.3-23.fc9.
    I have not tried monkeylove's suggestion.

Topic Closed

This topic has been closed to new replies.

About this Topic