WordPress.org

Ready to get started?Download WordPress

Forums

Windows 2003 and Permlinks; HTTP Error 404 (13 posts)

  1. craibuc
    Member
    Posted 8 years ago #

    I'm having an error w/ Permalinks. My hosting company uses Windows 2003, with PHP support.

    Similar threads on the subject indicate that 'index.php' needs to be in the structure.

    I believe that i've entered this correctly:
    Structure: /index.php/%category%/%postname%/
    Catgory: blank.

    I get the 'HTTP Error 404' error. If I don't use Permalinks, everything works correctly.

    For a demonstration, see http://www.cogniza.com/blog/.

    Has anyone been able to resolve this?

    Thanks,

    Craig

  2. Try it without the /%category%/ tag.

  3. selbmag
    Member
    Posted 8 years ago #

    Does your host have ISAPI_Rewrite or similiar? otherwise the permalinks wont work on Windows 2003. We use ISAPI_Rewrite on Windows 2003 and got WordPress working after some investigation and testing. See here

    http://www.selbmag.co.uk/2005/10/wordpress-and-isapi_rewrite/

  4. craibuc
    Member
    Posted 8 years ago #

    Structure now: /index.php/%postname%/

    still producing the same error.

    i will speak to my hosting company about the httpd.txt file. can it be located in my virtual directory? will it affect other co-hosted sites?

    thanks.

  5. selbmag
    Member
    Posted 8 years ago #

    It is a httpd.ini file (the txt extension is so you can view it). It will only work if your host has ISAPI_Rewrite installed on a per site basis and if you use the same permalink string as mentioned. You can of course edit the Rewrite rules to your specific permalink set-up

  6. craibuc
    Member
    Posted 8 years ago #

    As it has global consequences, I doubt they will install it. I guess I'm stuck with the regular Url.

  7. craibuc
    Member
    Posted 8 years ago #

    they offered to install LinkFreeze (http://www.helicontech.com/linkfreeze/). Has anyone heard of it?

  8. selbmag
    Member
    Posted 8 years ago #

    Yeah but it will not do what you want as it only re-writes specific URLs. It *might* work but to be honest it is likely to give you some issues with some URLs working and some not.

    If they do it right it has ISAPI_Rewrite global consequences.

  9. selbmag
    Member
    Posted 8 years ago #

    Sorry just noticed. I should have said ISAPI_Rewrite will have NO global consequences when done right.

  10. craibuc
    Member
    Posted 8 years ago #

    can you elaborate on how this is done right?

  11. selbmag
    Member
    Posted 8 years ago #

    They will need to buy the software and install it on the Master IIS site in IIS6. Provide RX permissions to the Anon_user group they use for shared website owners on the ISAPI_rewrite.dll.

    Users can then simply upload a httpd.ini file if they want to use ISAPI_Rewrite and those that do not have a httpd.ini file will not be affected.

  12. craibuc
    Member
    Posted 8 years ago #

    is the httpd.ini file stored in the root of each virtual directory?

  13. nhlhomer
    Member
    Posted 8 years ago #

    I cannot get anything of the form .../index.php/xyz/abc to work on my IIS 5.1 / PHP 5 / WordPress 2.0 install. PHP is installed as an isapi DLL and seems to be working just fine. However, if there is a path that extends past the index.php (such as http://thehost/wordpress/index.php/category/news/), IIS returns a 404. It’s as though IIS is treating the index.php as a folder instead of passing control to this php file. I have installed urlscan and set the AllowDotInPath parameter to 1, just to make sure this wasn’t the problem. I tried putting a php.ini file with the two cgi.fix_pathinfo = 1 and cgi.force_redirect = 0 entries into my \Inetpub\wwwroot\ folder, but I am still getting 404 errors.

    Is there any basic configuration of IIS or PHP that I need to do so that index.php does not get treated as a folder? Thanks so much for all the help!

Topic Closed

This topic has been closed to new replies.

About this Topic