WordPress.org

Ready to get started?Download WordPress

Forums

Botnet Attack Blocker
[resolved] Will this work with Multisite and Wordfence? (13 posts)

  1. PhilEsq
    Member
    Posted 1 year ago #

    Will this work with Multisite?

    Will this work with Multisite and Wordfence?

    http://wordpress.org/extend/plugins/botnet-attack-blocker/

  2. cheesefather
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, it works fine with Wordfence, but I haven't tested it myself on a Multisite as I haven't got access to one. I see no reason why it wouldn't work, but would be interested to hear any feedback from anyone able to test this. Thanks.

  3. PhilEsq
    Member
    Posted 1 year ago #

    Thanks.

  4. bbergman
    Member
    Posted 1 year ago #

    I had a weirdness today with WordFence. A new site I launched, and as always, I installed WordFence. This time I also wanted to try out your plugin, so I installed and activated it as well. When I went to the admin page for WordFence, it threw a web server error. Whoops.

    I was able to go back to wp-admin and disable your plugin, and then WordFence worked fine. I configured it completely and ran a scan and no problems.

    On a whim, I tried re-activating your plugin and this time it seems okay. No issues getting to the WordFence admin page, and your plugin seems to be working. Just thought I'd tell you in case you hear of other similar events. Might have been a function of the order of activation or something. If I can help with debugging, please let me know.

    Thanks!
    Bruce Bergman

  5. cheesefather
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, thanks for letting me know - do you remember what the error message said? Was it a standard internal server error (code 500)? I'll have a look at the init code again and see if I can spot the problem. Thanks :)

  6. PhilEsq
    Member
    Posted 1 year ago #

    That post should be moved as it has nothing to do with Botnet Attack Blocker and Multisite working with Wordfence.

  7. bbergman
    Member
    Posted 1 year ago #

    Oh geez, forum nazis now... Good gracious.

    Forget it, I'll just start a NEW thread about concerns about Botnet Attack Blocker not working with WordFence. That will be so very different than this one here.

    Sheesh...lighten up people.

    CheeseFather: thanks for your help. I'll contact you offline about this.

  8. PhilEsq
    Member
    Posted 1 year ago #

    I tried installing in Multisite but I don't see the settings in the Network dashboard.

    I tried to access one of the subsites and got:
    Warning: Cannot modify header information - headers already sent by (output started at /home/jonathaw/public_html/wp-content/plugins/iq-block-country/iq-block-country.php:196) in /home/jonathaw/public_html/wp-includes/pluggable.php on line 876

    I deactivated iq-block-country and the error was gone.

  9. cheesefather
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, the plugin is not working properly with Multisite installations at the moment I'm afraid, there will be a fix in the next minor version. Sorry about that.

  10. PhilEsq
    Member
    Posted 1 year ago #

    That would be great!

  11. PhilEsq
    Member
    Posted 1 year ago #

    I would be willing to make to donate if you can make it work properly with Multisite.

  12. cheesefather
    Member
    Plugin Author

    Posted 9 months ago #

    The latest version (1.8) now works with multisite!

  13. PhilEsq
    Member
    Posted 9 months ago #

    I had installed it anyway due to the attacks and it seemed to have solved the problem and I have not had any errors. I mentioned your plugin to several hosting companies and they were very interested in it and said they would recommend it. I also included it in my page at http://www.top10googleresults.com/speedupwebsite

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.