WordPress.org

Ready to get started?Download WordPress

Forums

Will there be a fix for old WordPress installs for multisite functionality? (17 posts)

  1. jonnylons
    Member
    Posted 3 years ago #

    I have wordpress blogs that are older than the 30 day limit. I want to upgrade them to offer multisite, but the only option is to use subdomains. If you host on Godaddy this is not an option.

    I have tried several different things. I have created a fresh install of 3.0.1 and imported my data from the old site. I then went into the Settings > General and changed the site and blog URLs to the new domain name and pointed that domain to the new sub-directory. But when I tried to update to multisite, it said my site was too old (now infamous 30 day error...).

    I have run out of ideas and have literally tried everything. Are there plans to have future releases that will fix this? I am thinking of just waiting for help to arrive.

  2. According to the Codex documentation:

    You cannot choose Sub-directory Install in the following cases:
    -If your existing WordPress installation has been set up for more than a month, due to issues with existing permalinks. (This problem will be fixed in a future version.)

    I'm sure it'll be fixed soon.

  3. jonnylons
    Member
    Posted 3 years ago #

    I hope so. I have spent the last week trying to migrate all my sites to a new server and in the process, some I have been trying to upgrade to offer multisite functionality. Was just going to use MU like I used, too! LOL! Thanks for the hope, James.

  4. Are there plans to have future releases that will fix this?

    Yes, this is temporary.

    But there IS a workaround, which we've covered extensively here in the forums. :D

    basically, go through the install, leaving it subdomain. then edit the config (yes, again) to change it from subdomains true to false. this makes it subfolders.
    But! The main blog gets the /blog/ permalink stuffed in the url, so then you need to disable that.

  5. Or make an .htaccess redirect to forward to it :)

    Either works.

  6. billsaysthis
    Member
    Posted 3 years ago #

    Andrea_r: Any ETA for this fix? Is it in 3.1-alpha?

    Failing that can you point to a forum post which gives explicit instructions for the workaround? I searched on a number of terms (upgrading 3.0.1 sub-directory fix, 3.0.1 sub-directory fix, upgrading 3.0.1 sub-directory install, etc...) and found nothing useful.

    Thanks!

  7. basically, go through the install, leaving it subdomain. then edit the config (yes, again) to change it from subdomains true to false. this makes it subfolders.

    Seriously.

    Once it's installed and you have a first post, go into wp-config and change define( 'SUBDOMAIN_INSTALL', true ); to define( 'SUBDOMAIN_INSTALL', false );

    Magic :)

  8. billsaysthis
    Member
    Posted 3 years ago #

    ipstenu: Thanks!

    But! The main blog gets the /blog/ permalink stuffed in the url, so then you need to disable that.

    This part is still unclear for me. Once created the path and siteurl for a blog cannot be altered, so I'm not certain how I would disable this.

  9. As it so happens... Andrea and I talked about that :)

    http://code.ipstenu.org/switching-to-wordpress-multisite-breaks-links/

  10. billsaysthis
    Member
    Posted 3 years ago #

    Okay, I figured out where to make that change. Created /newblog.

    Now if I go to blog.example.com/newblog/wp-admin I get a 404 and the 'Apologies, but the page you requested could not be found. Perhaps searching will help' error page.

  11. Did you update your .htaccess file for MuliSite?

  12. Failing that can you point to a forum post which gives explicit instructions for the workaround? I searched on a number of terms (upgrading 3.0.1 sub-directory fix, 3.0.1 sub-directory fix, upgrading 3.0.1 sub-directory install, etc...) and found nothing useful.

    becasue it;s under "remove /blog" - for which you will find a bajillion results for.

    Also - .htaccess serves up the subfolder blogs. Make sure it's there and being read.

  13. billsaysthis
    Member
    Posted 3 years ago #

    Did you update your .htaccess file for MuliSite?

    I have one but didn't change the .htaccess from the lines shown when I enabled MultiSite (that is, when I was shown the wp-config additions). What changes are necessary?

    Amusingly, "remove /blog" never occurred to me as a search term since that wasn't how I thought of the problem.

  14. I have one but didn't change the .htaccess from the lines shown when I enabled MultiSite (that is, when I was shown the wp-config additions). What changes are necessary?

    the ones that were shown, right under where it said

    "paste this in your htaccess file, replacing previous rules"

  15. billsaysthis
    Member
    Posted 3 years ago #

    Andrea_r: Yes, those ones are the ones I put in my .htaccess.

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
  16. You have subdfolders. Try this one instead:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress

    The directions you got were for subdomains, which is fine, but it IS different on SubFolders right now :)

  17. billsaysthis
    Member
    Posted 3 years ago #

    Awesome, ipstenu, that was the answer!

Topic Closed

This topic has been closed to new replies.

About this Topic