WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[closed] Will Pay: Preload Always Randomly Missing - files made, then deleted later (25 posts)

  1. Norbert McDorbert
    Member
    Posted 1 year ago #

    Preload Is alwayws being removed and randomly missing.

    I am using recommended settings, and have more than enough memory to have it work. It seems that that preload is constantly being deleted when it regenerates, but it randomly doesnt regenerate.

    It works fine for a while, then stops

    Then works fine for a while then stops.

    I have garbage collection set to a massive amount of time, preload every 120 minutes, yet still going to sites to see them empty. I will force a preload, that works, then it stop

    Can you fix this? I will gladly donate/pay for service. Please let me know!.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Darrel2013
    Member
    Posted 12 months ago #

    I'm having a very similar problem.

    My cache was set to preload all pages once per day (static real estate site with about 600 pages), with garbage collection off, but on occasions the cache would just be empty for no obvious reason, or would just have a few very old cached files in it.

    Manual preload always works fine and I cant see anything wrong with the cron tasks. It's just the automatic preload that sometimes fails, or maybe it succeeds and then gets deleted.

    I have now set it to preload every 6 hours and have turned garbage collection on, set to once per day. We'll see what difference that makes, if any.

    If it came to the worst I could just turn off the automatic preload and run it manually once a day, but it should work on its own.

    Apart from that this plugin seems to be excellent. I tried W3TotalCache but that was an endless source of problems and errors.

  3. Norbert McDorbert
    Member
    Posted 12 months ago #

    I say think it has to do with their job timing out during load. Mine is running for an entire multisided one giant task, so sometimes it works and reloads cash but most the time it fails. I only have 100 sites total on the network

    However I am running on a VPS server from a reputable hosting company with under 2% average load on my CPU allotment. So I should have more than enough resources properly run.

    I wonder if instead of clearing all-cash files at the start of the preload running it could be modified to allow it to overwrite?

    Or can you see any other possibility why this keeps failing?

  4. Darrel2013
    Member
    Posted 12 months ago #

    Presumably if it was just timing out then there would be no difference between a manual preload and an automatic one.

    Our site is just on a run-of-the-mill shared host but it works fine and for the limited number of pages (600) and hits (under 1000/day) we have I see no reason to change anything. All I'm interested in is that these static pages get delivered as fast as possible, and that the cache gets rebuilt or verified once every 24 hours. I've spent quite a lot of time optimising the scripts and css, optimising the images etc, and generally minimising everything as much as possible. All it needs now is for the cache to be full all the time.

  5. Norbert McDorbert
    Member
    Posted 12 months ago #

    True. But why only is it a problem on reloading the preload.

    Also I thought pre load was to act like a permanent copy infrequently updated. It would serve preload but then build cache on user visit. Serving cache unless preload happens

    However it doesn't do that either unless I misread docs

    The preload thig was working for me on a vps with 2gb ram, 4 processors, and 4x hdd priority for a while. But a few updates knocked that out

    I don't think people notice the preload issues to be honest. If they get massive visitors the cache is served.

  6. Darrel2013
    Member
    Posted 12 months ago #

    I suspect you are correct about most people not noticing if the preload doesnt work.

    As far as I know the preload is just an automated procedure for visiting each page and thus filling the cache, instead of just waiting for a real visitor to visit the page and fill it.

    Looking at the cache folder via FTP I can see that the "delete cache" button does indeed delete all the cache files and folders and then once "preload now" is clicked the folders rebuild themselves, at a rate of about 1 page every few seconds.

  7. Darrel2013
    Member
    Posted 12 months ago #

    One day on with the changes I mentioned above and my cache is still full. It has regenerated 3 times, and nearly all the folders and files in the cache directory have date stamps within an hour of each other. Just a few files and folders had an earlier date stamp when I checked just now. I have deleted these folders manually, to see what happens.

  8. Darrel2013
    Member
    Posted 12 months ago #

    Cached emptied itself for no obvious reason shortly after the most recent preload. I'd love to work out what's going on here.

  9. Donncha O Caoimh
    Member
    Plugin Author

    Posted 12 months ago #

    I have seen this happen to others but I can't remember why. Have you tried running the debug log? There's going to be lots of stuff in there you can ignore but the end of the preload triggers something that will be captured in the log.

  10. Darrel2013
    Member
    Posted 12 months ago #

    Thanks for the response. No, I havent tried that but I will now. Will report back.

  11. Darrel2013
    Member
    Posted 12 months ago #

    I think my problem has something to do with custom post types as these seem to be the only ones that arent working properly. This site is almost entirely made up of these custom types, with just a few regular pages.

  12. Darrel2013
    Member
    Posted 11 months ago #

    Seems like the custom post thing was a red herring.

    I couldnt see anything obvious in the debug logs so I tried setting the cache timeout to zero and the scheduler to various very long times. I found that no matter what settings I chose for these, the cache-related cron job "watcher" and the wp_cache_gc job were still being created for much shorter periods than I had selected, and this seemed to correspond with my cache being emptied.

    So I deleted the watcher cron job altogether (what does it do anyway?) and manually altered the cache_gc job to 3 years. So far my cache has stayed full and it is being rebuilt according to the preload setting (24 hours) that I selected. Fingers crossed.

    One other thing I dont understand: why do I need legacy caching and these checks for emptying it? Cant it just be completely turned off if I'm using Supercache?
    It seems to me that a couple of tick-boxes in the advanced settings page to deactivate both unwanted services would be easier to understand than the "cache timeout set to zero", and the timer and schedule boxes that currently cant be turned off.

  13. azazure
    Member
    Posted 11 months ago #

    I'm having the same problem with preload. I have disabled the refresh and garbage collection completely and it still periodically dumps everything.

  14. Maraki
    Member
    Posted 11 months ago #

    @Darrel2013 - I am having exactly the same problem... does your solution work so far?

    thanks x

  15. Jens Waern
    Member
    Posted 11 months ago #

    Having same troubles, randomly empties while caching, sometime breaking preload-process and sometimes not.

  16. Maraki
    Member
    Posted 11 months ago #

    so it seems a lot of people have expressed the same problem - is there any recommended solutions?

  17. azazure
    Member
    Posted 11 months ago #

    I haven't found anything yet. I'm hoping the author will respond.

  18. jondaley
    Member
    Posted 11 months ago #

    I'm not the developer of this plugin, but I happen to be logged on and I use supercache a bunch, and haven't had any trouble with preload, so I could take a look at it for you ($$) if you want. I work fastest if you have ssh access.

  19. Jens Waern
    Member
    Posted 11 months ago #

    From reading the logs it seems the problem (for me atleast) always starts with wpsc wanting to clear cached index file in my root (/wp-content/cache/supercache/[mydomain/]), it then proceeds to delete ALL index files in all subdirs (ie all cached files).

  20. Maraki
    Member
    Posted 11 months ago #

    @jenswaern - how can i verify that i have the same problem ?

    what should i look for in the logs ?

  21. jt70
    Member
    Posted 11 months ago #

    I am seeing similar behaviors with the cache truncating unexpectedly. Last night I ran a preload, and almost immediately the cache cleared, but I had already deleted the cache right before. This morning I noticed I had a cache with the stale-est files at about 9500 seconds. I have expiry set at 86400. I just looked again, and the oldest were at 1341. So, it appears to not be linked to the preload for me, and it appears to not be completely deleting the cache. Of note, my garbage collection was set by time and once per day.
    So it appears, at least in my case, that the expiry time is not working and it is running garbage collection at unexpected times. I seem to recall something about this in the past where the garbage collection was not able to update the defaults, but it has been a long time.

  22. Norbert McDorbert
    Member
    Posted 11 months ago #

    The Pre-load clears the cache when it refreshes.

    So if it refreshes because a comment or post on page, or you have a setting set so that when it updates, including all preload, it will happen. Otherwise it'll happen and it scheduled time. It'll empty the cache, and then usually it seems that Something prevents it from preloading everything back.

    It seems I've been having less problems in switching to PHP mode. I was using the HT access version.

    Curious, what type is everyone using currently?

  23. jt70
    Member
    Posted 11 months ago #

    Just did some research, and found a similar thread. It is more focused on unexpected deleting of the cache, but if it happens during the preload, I would suspect that it would look like an incomplete preload.
    At the time, I found that it seemed to be linked to comments. When one would get moved to the spam queue or when one was deleted, it would affect the cache. I suspect it is triggering the garbage collection.

    My thoughts are that there are two issues I am having.
    1. My garbage collection settings do not save, so it is staying at 3600.
    2. The comment/spam issue makes gc run frequently. (This might possibly also be due to another setting not saving).

    I think I will try manually adjusting the default settings in wp-cache and see what happens.

    The original thread on this was at http://wordpress.org/support/topic/plugin-wp-super-cache-garbage-collection-wont-save-correct-option?replies=17

  24. jt70
    Member
    Posted 11 months ago #

    Just noticed that a new spam message got moved to the spam folder, and it deleted the entire cache, regardless of age/timeout setting. Anyone else seeing this?

  25. jt70
    Member
    Posted 11 months ago #

    Update...
    I went into the database and closed out pingbacks on all old posts, and without any new items leaving the comments folder, the cache did not purge. Note: I did overwrite the default setting for timeout in the wp_cache file.
    But...when I updated a post, it did clear the cache. I confirmed that I had the check box unchecked for "Clear all cache files when a post or page is published or updated."
    I seem to be having a problem with my settings not updating the plugin, even though they are showing on the admin. This is leading to the undesired purge of the cache.

    Hope that helps with troubleshooting.
    Jeff

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic