WordPress.org

Ready to get started?Download WordPress

Forums

Recent Posts FlexSlider
[resolved] Will not show manual excerpts any more, only automatic :( (3 posts)

  1. Emma_W
    Member
    Posted 7 months ago #

    Hi,

    My client has been using Recent Posts Flexslider for months and has been very happy with it. However, after an update today (I'm not sure if it was a core update or not, and they aren't able to tell me) the slider has started showing the first 100 words of the post, rather than the custom excerpts they had set. This is a big problem for them and we need to fix it ASAP if possible - any ideas why it won't show a manual excerpt any more?

    I can't remember if there used to be a separate setting to show manual versus automatic excerpts, but there certainly isn't now.

    Can anyone suggest anything?

    http://wordpress.org/plugins/recent-posts-flexslider/

  2. David Laietta
    Member
    Plugin Author

    Posted 7 months ago #

    Hi Emma,

    There isn't a setting to show manual versus automatic (but I'll take that into account for future versions.) The client can downgrade to v1.4, but there are enough changes in v1.5 that I'd suggest the switch. If you are they are alright with doing minor changes to the plugin code, a function needs to be changed.

    On line 49 of the file recent-posts-flexslider/views/display.php, you'll need to change this:

    $output .= '<p>' . $display->recent_post_flexslider_excerpt(get_the_content(), $excerpt_length) . '</p>';

    to this:

    $output .= '<p>' . $display->recent_post_flexslider_excerpt(get_the_excerpt(), $excerpt_length) . '</p>';

    This will let it use manually set excerpts. Note that tags are also stripped from the excerpts in the new version, as they are from manual displays.

    Thank you for using the plugin!
    David

  3. Emma_W
    Member
    Posted 7 months ago #

    Thank you so much. I guess they must have updated your plugin in that case - fixed it now and it's all working.

    This is absolutely superb support on your part. I'm really impressed. Thank you!

Reply

You must log in to post.

About this Plugin

About this Topic