WordPress.org

Ready to get started?Download WordPress

Forums

Wierd date in my RSS feed (3 posts)

  1. erikcw
    Member
    Posted 7 years ago #

    My rss feed (feed=rss2) has a wierd pubDate in it. One of the nested pubDates in listed as - but none of my posts are using this date.

    <pubDate>Tue, 30 Nov 1999 00:00:00 +0000</pubDate>

    Why is this happening? How do I make it display the correct date?

    Thanks!
    Erik

    <?xml version="1.0" encoding="UTF-8"?>
    <!-- generator="wordpress/2.2.1" -->
    <rss version="2.0"

    xmlns:content="http://purl.org/rss/1.0/modules/content/"
    `xmlns:wfw="http://wellformedweb.org/CommentAPI/"
    xmlns:dc="http://purl.org/dc/elements/1.1/"
    >

    <channel>
    <title>LYBP</title>
    <link>http://www.myblog.com/blog</link>
    <description>My Blog</description>
    <pubDate>Sun, 22 Jul 2007 19:04:41 +0000</pubDate>

    <generator>http://wordpress.org/?v=2.2.1</generator>
    <language>en</language>
    <item>
    <title>New LYBP Blog</title>
    <link>http://www.myblog.com/blog/?p=1</link>
    <comments>http://www.myblog.com/blog/?p=1#comments</comments>

    <pubDate>Tue, 30 Nov 1999 00:00:00 +0000</pubDate>
    <dc:creator>Erik</dc:creator>

    <category><![CDATA[Uncategorized]]></category>

    <guid isPermaLink="false"></guid>
    <description><![CDATA[Hello, World!`

  2. Chris_K
    Member
    Posted 7 years ago #

    Try it with a real post (not the default "first post") and see if you have the same issue.

  3. erikcw
    Member
    Posted 6 years ago #

    An update for anyone else with this problem. It was an issue with the default first post. the post_date_gmt in the database was set to 0000-00-00 00:00:00 - I replaced it with the real timestamp - fixed!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.