WordPress.org

Ready to get started?Download WordPress

Forums

Rotating Tweets (Twitter widget and shortcode)
[resolved] Width & Resizing (54 posts)

  1. SFMichael
    Member
    Posted 1 year ago #

    Great plugin, however it seems to ignore my sizing constraints.

    For example i've set the widget to have a 33% width however it will ignore this. This does not always happen though its just one of those annoying things that occasionally occurs.

    Could be greatly improved if made responsive.

    http://wordpress.org/extend/plugins/rotatingtweets/

  2. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Can you send me a link to the site? It is going too big or too small?

    If it's too big, it generally needs something like:

    #sidebar {
      word-wrap: break-word;
    }

    or

    .rtw_main {
        word-wrap: break-word;
    }

    and if it's too small, the development latest version should address this... but if it doesn't, you may be able to fix things by setting the width of li.widget_rotatingtweets_widget or div.widget_rotatingtweets_widget depending on your set-up.

    Making it fully responsive will be difficult because of the way jQuery.cycle is written, but - in time - I will rewrite the JavaScript to support the new version of jQuery.cycle

    Martin

  3. SFMichael
    Member
    Posted 1 year ago #

    http://dev.silverfishstudios.co.uk/michael/news/

    Widget is in footer.

    Thats my link, as i say its a rather random occurrence. It will be too big if its ignores width.

    Speedy response thanks

  4. SFMichael
    Member
    Posted 1 year ago #

    Ment was a speedy response..

    I think i know what is happening, if i shrink the browser and refresh it when its around 1/3 of the size the widget will become 100% then when i stretch the browser again it appears as if it is ignoring my width, if that makes sense.

    Its down to my responsive website and a non a responsive widget.

    :D Thanks any way!

  5. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Looks like it's the word-wrap problem. If you get a really long word or link, it will force the widget to go wider.

    I'll add the word-wrap CSS to the development version CSS file, but you might want to try it in your own stylesheet.

  6. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    I'll also start investigating whether it's possible to adjust the javascript allow for a resize of the tweets when resizing the page.

  7. Jersey98
    Member
    Posted 1 year ago #

    Hi, I have a small problem after the last update RT. Update change tweet rotation size, before it was ok. The length is too large. Please take a look at it. My web is http://www.kabelovky.net.

    Sorry for my english ;-)

    Thank you

  8. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Does the latest development version of the plug-in work better?

    Martin

  9. Jersey98
    Member
    Posted 1 year ago #

    No. The problem is that the length of the text box (where writting text) don't adjust size the column in the topic! Part of the text in line is hidden, is here problem with formatting text pole, not adjust the width automatically.

    Before update latest version plugin has not been problem with nothing. Size line was ok.

  10. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Which version were you using before the upgrade?

    Martin

  11. Jersey98
    Member
    Posted 1 year ago #

    1.3.17 Martin may be problem on site of Twitter. When I see web UI my twitter account, I don't see number of follower :-/

    http://2i.cz/2i/i/51541b7b/3006b882b455742e21c44c6fc6a43b42/d542c1eb38.f.jpg

    http://2i.cz/2i/i/51541cd3/295abca202604d95f369177d8ed9c414/610685af7c.f.jpg

  12. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    I think the latest development version should solve this.

    Martin

  13. Jersey98
    Member
    Posted 1 year ago #

    I try version from your link, but problem persists :-(

    Twitter Web UI problem was Czech translation pack (beta language) in setting Twitter Web UI, after switching english language, working ok.

  14. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    I think you're using an older version. Can you download it and try again?

    Martin

  15. Jersey98
    Member
    Posted 1 year ago #

    Yes, but same problem. Martin, all plugins are latest version. Try wait on your next version and I see...Tried your plugin on a different template, the same problem.

    http://2i.cz/2i/i/51589564/dcee4c140cf5c5b163d0c5300e57a6da/ac0685af7c.f.jpg

    http://2i.cz/2i/i/51589543/ccf3a5bec95119562024787c5d22cfd0/53f97a5083.f.jpg

    I don't know where the problem, hmm :-/

    Petr

  16. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    It really isn't. Believe me.

    The version of the Javascript hosted on your site - http://www.kabelovky.net/wp-content/plugins/rotatingtweets/js/rotating_tweet.js - is not the same as the javascript included in the Development Version of Rotating Tweets - which you can see at http://plugins.svn.wordpress.org/rotatingtweets/trunk/js/rotating_tweet.js

  17. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    I've updated it again. If you update to the latest version - and then replace the /js/rotating_tweet.js with http://plugins.svn.wordpress.org/rotatingtweets/trunk/js/rotating_tweet.js, it may work!

  18. Jersey98
    Member
    Posted 1 year ago #

    Martin, I tried many combination(delete plugin, clear WP cache, trying load clear version plugin, delete manual from FTP, create new token) but not working. I have latest version and replace js, from this page.

  19. Jersey98
    Member
    Posted 1 year ago #

    I tried delete Chrome, Opera (browser cache) and working :-)

    But I tested it in Firefox and IE 10 (after delete FF and IE cache), but not working in this browsers, hmm. I've latest version of all browsers. Perhaps it will help.

    Thx many much Martin, for your time! Good job!

  20. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Here's a solution I tried with someone else:

    Can you put:

    div.widget_rotatingtweets_widget, div.rotatingtweet, div.widget_rotatingtweets_widget div.widget-title {
    	max-width: 220px;
    }

    into your template CSS or into rotatingtweets.css in the wp-content/uploads directory?

  21. Jersey98
    Member
    Posted 1 year ago #

    problem resolved, all browsers working ok, many thanks Martin. Good work :-)

  22. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    The latest version should adjust for column widths automatically and should also be responsive! :-)

  23. SFMichael
    Member
    Posted 1 year ago #

    Excellent work seems to work well.

  24. Jersey98
    Member
    Posted 1 year ago #

    Thx Martin :-)

  25. ellebeaux
    Member
    Posted 1 year ago #

    The new responsive resizing is wonky for me (probably interacting weirdly with my responsive theme), is there a way to turn it off?
    Thanks!

  26. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    Ellebeaux,

    Not currently. Can you send me a link - or, if it's a publicly available theme, tell me which one it is?

    Martin

  27. ellebeaux
    Member
    Posted 1 year ago #

    Strangely, it seems to have sorted itself out...spooky. Well, never mind–thanks for a great plugin!

  28. Martin Tod
    Member
    Plugin Author

    Posted 1 year ago #

    I rewrote the responsiveness code/algorithm after the first version. Perhaps it was updating to the latest version that fixed the problem?

  29. grifmang
    Member
    Posted 1 year ago #

    Hey Martin is there anyway to make the text a link to the twitter page?

  30. grifmang
    Member
    Posted 1 year ago #

    My apologies, I posted in the wrong thread ...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.