WordPress.org

Ready to get started?Download WordPress

Forums

Widgets page missing from WPMU member blog admin (69 posts)

  1. terjefevaag
    Member
    Posted 3 years ago #

    "Widgets" should appear under "Appearance" on the left side options of the wp-admin.

    Appearance
    > Themes
    > Widgets

    "Widgets" is missing. I haven't done any updates recently except upload 2 dozen themes. I have deleted all those themes, thinking they caused the problem, but this did not fix the problem.

    You can see it for yourself:

    http://totoymola.religioner.no/wp-admin/
    username: *obfuscated*
    password: *obfuscated*

  2. It's the theme you are currently using on that blog. It needs updating in the functions.php file of that theme.

  3. terjefevaag
    Member
    Posted 3 years ago #

    even the default theme does that.

  4. terjefevaag
    Member
    Posted 3 years ago #

    is this what you're referring to?

    add_theme_page($themename." Options", "".$themename." Options", 'edit_themes_options', basename(__FILE__), 'mytheme_admin');

    it doesn't help.

  5. terjefevaag
    Member
    Posted 3 years ago #

    oh well it seems that nobody has any idea about this annoying bug.

  6. Which theme do you think is default?

    It should be twentyten.

  7. terjefevaag
    Member
    Posted 3 years ago #

    yes, even twentyten does that. whatever theme i try, it's still missing "Widgets" under "Appearance" in wp-admin.

  8. terjefevaag
    Member
    Posted 3 years ago #

    to give you a better idea of what i'm talking about, please view the screenshot:

    http://img7.imagevenue.com/img.php?image=84555_annoying_122_30lo.jpg

    or

    http://religioner.no/annoying.jpg

  9. Something's not right on your setup. I don't think anyone else is having the is problem. I'd reinstall the files for WordPress.

  10. terjefevaag
    Member
    Posted 3 years ago #

    i downloaded the latest wordpress mu version 3.0 and reinstalled the files but it didn't resolve the problem. it seems that this is a configuration problem. i have direct access to the mysql database. is there any sql query that i could run to fix this problem?

  11. terjefevaag
    Member
    Posted 3 years ago #

    You can see it for yourself:

    http://totoymola.religioner.no/wp-admin/
    username: totoymola
    password: p@ssw0rd

    mod please don't obfuscate my username and password because i'm trying to find someone who can help me with this annoying wordpress bug. it is my website and it is my choice to reveal the password to a temporary blog account that i made for testing purposes.

  12. Your not an admin of your site :) This happens sometimes.

    Okay, a lot of times.

    Go to http://mu.wordpress.org/forums/tags/site-admin

    Somewhere in there will be fixes.

  13. terjefevaag
    Member
    Posted 3 years ago #

    i am an admin of my site

    i have access to http://religioner.no/wp-admin

    strangely, the "Widgets" option appear in the admin backend, but not on blog users backend.

  14. terjefevaag
    Member
    Posted 3 years ago #

    see the "Widgets" option appear under "Appearance" here:

    site admin backend (http://religioner.no/wp-admin/
    http://religioner.no/annoying2.jpg

    but not here. blog user backend (http://totoymola.religioner.no/wp-admin)
    http://religioner.no/annoying.jpg

  15. That's not what I mean.

    You are not the admin CODEWISE of your site. Any user who has access can log in, but if YOU, as the logged in account, cannot add other USERS, then YOU are not the admin :) It's really that simple.

    Your not the admin.

    Look at http://religioner.no/annoying2.jpg

    At the top see how it says SUPER ADMIN?

    You DO NOT have that on the other site. Thus it is proven: You are not the admin. You have to fix this on the SQL side. The link I gave you will give you a list of posts where people had the same problems, and how they fixed it.

  16. terjefevaag
    Member
    Posted 3 years ago #

    username: totoymola

    is not supposed to be an admin. it is an admin for
    http://totoymola.religioner.no

    but not http://religioner.no
    where only i (username: admin) have access

    i used to have "Widgets" under "Appearance" when logged in as "totoymola" at http://totoymola.religioner.no/wp-admin

    i haven't done any major changes except upload different themes and install a couple of plugins. i thought that might have messed it up.

    you might want to check these screenshots:
    http://religioner.no/edit-user.jpg
    http://religioner.no/list-users.jpg

  17. terjefevaag
    Member
    Posted 3 years ago #

    in my super admin options, i checked

    "Allow site administrators to add new users to their site via the "Users->Add New" page."

    now, totoymola can add new users, so he's definitely an admin for his blog. but still "he" is unable to see "Widgets" under "Appearance". the only item "he" sees there is "Themes". i hope you're not confused anymore as to what the problem is all about.

  18. The ID you gave me to log in with was not an ID that had admin access. IIRC, only Super Admins (and BLOG admins, not the same thing) can see and change widgets. Security yanno :)

    Just because the users screen SAYS an ID is an admin does not change the fact that, when logged in, you DO NOT get admin access. Right? We're agreeing that totoymola is listed as an Administrator of religioner.no

    totoymola.religioner.no, however, is a separate site.

    As ADMIN, go to Super Admin -> Sites and click on 'Edit' for totoymola the BLOG.

    Under the Site Users menu on the right, check what the permissions are for totoymola.

  19. terjefevaag
    Member
    Posted 3 years ago #

    Super Admin > Sites

    Edit Site - http://totoymola.religioner.no

    Site Users
    User Role
    totoymola Administrator

  20. Can you change the role?

    There's a known weird bug where sometimes you can't change roles, and I wonder if you've hit it.

    The other thing would be to add a second ID as administrator as well and see if THAT id has access as it should.

  21. If the user is an administrator of their own sub-blog, then YES they definitely should see the widgets menu.

    And TwentyTen should let them.

    Try disabling all your plugins to see if that clears it up.

  22. dexternica
    Member
    Posted 3 years ago #

    Hi,

    I wrote about the same problem in other topic, Andrea_r give me a solution but don't work, only show theme settings and the option for add widget not appear.

    terjefevaag have reason, only Super Admin can add widget, but not the administrator (than in past versions could without any problem).

    Thanks for your help and sorry for my bad english.

  23. terjefevaag
    Member
    Posted 3 years ago #

    i created another user "totoybato" and assigned it as administrator of BLOG "totoymola". still can't see "Widgets" under "Appearance" using TwentyTen. disabling all plugins did not fix the problem.

  24. I've tested on my own - an admin of another site can see what they need to.

  25. terjefevaag
    Member
    Posted 3 years ago #

    seems like not everyone is experiencing this problem. i'm really lost as to what is the cause of it.

  26. Did you try disabling all your plugins?

  27. dexternica
    Member
    Posted 3 years ago #

    I discovered something. If you create a new blog and assign to any user as an administrator, they will see the options for widgets and themes.

    It seems to be a new option, this option is needed in blogs created before the upgrade.

    I compared the wp_option tables old and new, and I found no difference.

    Any developer who has an idea or solution?

  28. http://codex.wordpress.org/Roles_and_Capabilities

    Well, by default when a user gets their own blog, they become an administrator of that blog. You failed to mention you changed this.

  29. dexternica
    Member
    Posted 3 years ago #

    Andrea_r we mention this in the topic, it's with the administrator role (not Super Admin) that can't add widgets in blogs created before upgrade.

    And now I say that in new blogs (after upgrade) any administrator user can add widgets (it's normal), that's why I think it's missing an option in old blogs.

    Thank for your help. :)

    I apologize for my bad English.

  30. sam_h1
    Member
    Posted 3 years ago #

    Interestingly, we just came across the exact same problem today

    I've posted something in the WPTavern forum (andrea, you've replied - apologies, this is yet another account name!)

    We upgraded from WPMU 2.8.6 to 2.9.2 to 3.0

Topic Closed

This topic has been closed to new replies.

About this Topic