WordPress.org

Ready to get started?Download WordPress

Forums

Widgets moved to bottom of page from Right Sidebar (9 posts)

  1. maverick12210
    Member
    Posted 4 years ago #

    Dear Members

    On my site - http://www.watchitornot.com which is powered by WP-BATS theme, On the main homepage all my widgets have been pushed to the bottom (footer) of the main page but when i open individual blog posts or pages then the widgets get displayed correctly in the right sidebar.

    How can i bring the widgets to the right sidebar correctly on the main homepage

    Awaiting your replies

    Thanks

    Maverick_12210

  2. You're missing a few </div> closing tags on index.php or home.php which are causing the sidebar to drop: [Invalid]Markup Validation of watchitornot.com - W3C Markup Validator. Scroll down in the validation report to see line numbers and source code.

  3. maverick12210
    Member
    Posted 4 years ago #

    thanks for the advice

    i tried disabling the plugins which i use to display Facebook Like other social media Share options (Digg Digg plugin & Tweetmeme plugin) and even uninstalled & re-installed the theme but still the problem persists, i even tried to install a new theme but the same problem occurs - sidebar appears on the bottom instead of the right, i tried deleting the most recent post to check if everything is ok but the same result - sidebar is on the bottom of the page

    Please help me

    Thanks

    Maverick_12210

  4. narellepy
    Member
    Posted 3 years ago #

    I am having the same problem. The widgets are perfect on all other pages except the home page. I have no idea how this happened as I didn't change anything, it just seemed to happen on its own. They were displaying fine last time I checked but not anymore. Please can someone help?

  5. doc4
    Member
    Posted 3 years ago #

    narellepy,

    Include your web address so we can take a look.

  6. narellepy
    Member
    Posted 3 years ago #

    http://www.askelleyeates.com
    I did a validation test and it came up with 32 results but I dont know how to fix it. Here's the link to that: http://validator.w3.org/check?uri=www.askelleyeates.com&charset=%28detect+automatically%29&doctype=Inline&group=0
    I feel the problem might be with several posts because I am using software that posts articles for me.

  7. narellepy
    Member
    Posted 3 years ago #

    I fixed a few of the problems - the ones that said end tag for element "p" which is not open. but that didn't fix the sidebar. Now it says I only have 11 errors but I have no idea how to fix those.

  8. narellepy
    Member
    Posted 3 years ago #

    I have also disabled all my plugins so that isn't the problem either.

  9. narellepy
    Member
    Posted 3 years ago #

    Hi, it has been over a week now and I am still having this same problem. Is there anyone who can please take a look. I can't understand why it is only the home index page that is affected.

Topic Closed

This topic has been closed to new replies.

About this Topic