WordPress.org

Ready to get started?Download WordPress

Forums

Mystique
Widgets in tab not work (2 posts)

  1. migrad
    Member
    Posted 6 months ago #

    Hi!

    From a days ago I have problems with the widgets in tab. When I push over a tab, the content not change, other times only show the tabs without content.

    I updated WordPress (3.6.1), all plugins and Mystique (3.3.2). I tried to disable all plugins, but not work.

    Last I modified the file jquery.atom.js the next lines:

    $('.sections', tabs).css('height', $('#' + $('.navi li.active a', tabs).attr('href'), tabs).outerHeight(true));
    
    var current = $('#' + $('.navi li.active', tabs).removeClass('active').find('a').attr('href'), tabs),
    next = $('#' + $(this).parent('li').addClass('active').find('a').attr('href'), tabs);

    For this lines:

    $('.navi > li > a[href]', tabs).bind(tabs.data('event') || 'click', function(event){
    
    var current = $($('.navi li.active', tabs).removeClass('active').find('a').attr('href'), tabs),
     next = $($(this).parent('li').addClass('active').find('a').attr('href'), tabs);

    So it work.

    I want post this, in case anyone happend the same.

    regards

  2. Raoul
    Member
    Posted 5 months ago #

    thanks!

    i also removed all occurrences of
    '#' +
    (including the +) from jquery.atom.js and all occurrences of
    "#"+
    (including the +) from jquery.atom.min.js and the tabs started to work again.

Reply

You must log in to post.

About this Theme

About this Topic