WordPress.org

Ready to get started?Download WordPress

Forums

widgets floating to the bottom of sidebar (10 posts)

  1. jonny.allen
    Member
    Posted 2 years ago #

    I'm a newbie so I apologise if I am covering a previous thread.

    I have inherited a site http://www.cagegravel.org.uk which was on the Vina theme. The sidebar widget was floating to the bottom. I have updated the theme to twenty-ten (latest version) and can see nothing obvious causing it.

    How do I get the widget area to float at the top of the sidebar?

    What am I missing?

    Any help would be greatly appreciated.

  2. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    your social link section is missing a closing </div> at the end.

    'compensated' by a stray </div> at the very end of the site after the closing of </div><!-- #wrapper -->

    therefore not showing any errors with the http://validator.w3.org/

  3. jonny.allen
    Member
    Posted 2 years ago #

    alchymyth. Thank you for such a rapid reply.

    Where do I find the social link section?

  4. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    I can't tell from looking at the finished code in the browser

    - are you using a plugin for the facebook and other links?

    - possibly this one: http://wordpress.org/support/topic/plugin-facebook-like-and-share-twitter-google-1-google-buzz-buttons-missing-closing-div-on?replies=3

    possibly just update the plugin (?)

  5. jonny.allen
    Member
    Posted 2 years ago #

    The site uses a plugin (google-button-wp/facebooktwittergoogle.php)

    I've also done something that has lost the "home Page" link so when going to http://www.cagegravel.org.uk it returns a "Not Found" message

  6. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    The site uses a plugin (google-button-wp/facebooktwittergoogle.php)

    that plugin seemed to have had this missing div error - http://wordpress.org/support/topic/plugin-facebook-like-and-share-twitter-google-1-google-buzz-buttons-missing-closing-div-on?replies=3

    have you uploaded a fresh version of that plugin to see if that solves your sidebar problem?

    ------
    the 'not found' possibly just means that you don't have any posts in your site and that you have lost the static front page setting:

    - have you changed anything in the 'settings - reading - Front page displays' ?

  7. jonny.allen
    Member
    Posted 2 years ago #

    Thank you so much for all your help.

    All is now resolved.

    Very greatly appreciated.

  8. jonny.allen
    Member
    Posted 2 years ago #

    Alchymyth. I have one further question which I am hoping you may be able to guide me through please.

    I am trying to have a Paypal Donate button on my site, ideally in the top widget area of the sidebar.

    I have pasted html text into the text area widget in my sidebar at http://www.cagegravel.org.uk.

    The link works in Firefox but not in Google Chrome or IE9.

    Does you have any ideas please?

  9. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    the link seems to be working for me in IE and Chrome - as I don't see the problem, I can't suggest anything.

  10. jonny.allen
    Member
    Posted 2 years ago #

    Thanks for all your help. I have spoken to Paypal and they advise that the buttons do not like being opened in frames.

    For those looking in future,

    Use the code generated by Paypal starting <form method...
    but replace the first line of code with
    <form method="post" action="https://www.paypal.com/cgi-bin/webscr" target="paypal">

    `

Topic Closed

This topic has been closed to new replies.

About this Topic