WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Widgets dashboard not working in 2.9.2 (32 posts)

  1. mickeyshout
    Member
    Posted 4 years ago #

    I just did a fresh install of 2.9.2 and the widgets dashboard is not working properly. When I try to drag a widget to the sidebar, it simply highlights the text, and will not drag. I have tried this with the default theme and several others. Same results. I have no plugins activated. Can anyone help?

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

  3. mickeyshout
    Member
    Posted 4 years ago #

    Thanks for the help! I just tried that--downloaded WordPress 2.9.2 again, deleted my wp-admin and wp-includes folders, and replaced them with fresh versions from the new download. Still no luck. Can't get anything to work on the widgets dashboard.

    My apologies for posting about this twice--I couldn't find my original post and I thought it had never gone through.

  4. findare1
    Member
    Posted 4 years ago #

    I am having the same exact problem. I too have installed the newest version of wordpress and my widgets dashboard is still not working. Any help on this would be greatly appreciated!

  5. findare1
    Member
    Posted 4 years ago #

    I just deleted all of my plugins and now the widget is working ok.

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    @mickeyshout: It could possibly be a memory issue.

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 16M try 32M:
    memory_limit = 32M ; Maximum amount of memory a script may consume (32MB)

    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 32M

    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '32M');

    4. Talk to your host.

  7. Onirem
    Member
    Posted 4 years ago #

    Hi, i have the same problem,
    I download and Upload to my server the new version of WordPress, i install all again, all are new, but don't work, and my memory limit is 32, what i can do?

    Thanks,
    Greetings From Chile

  8. smchugh
    Member
    Posted 4 years ago #

    The same thing happened to me and I've tried the hints above. I don't even have any plugins to delete! I thought it could be my theme (a Wootheme) but have switched back to Kubrik and the problem is the same - no drag and drop of widgets, and the Screen Options dropdown doesn't, er, drop down.

  9. Onirem
    Member
    Posted 4 years ago #

    Hi, i have the answer for the problem, in my case, was a pluggin old, but work... maybe it's your problem too

    Greetings!

  10. aj3x2
    Member
    Posted 4 years ago #

    Possibly a javascript error? Of course like everyone else, widgets don't work, upload insert don't work, clicking on screen options does nothing. Not working in IE7 or firefox. It sure would be nice to be able to use the widgets feature and other cool stuff depending on JScript.
    tried disabling plugins, fresh install, own directory install, bare bones, no luck.

    I get this Jscript error in my IE7 browser when I load the admin interface.
    error: "Done, but with errors"

    Line: 2
    char:77
    error: invalid character
    code:0
    URL:http://mydomain/wp-admin/

    Line: 2
    char:1
    error: 'sack' is undefined
    code:0
    URL:http://mydomain/wp-admin/

    Line: 10
    char:2
    error: 'g_execphp_feature' is undefined
    code:0
    URL:http://mydomain/wp-admin/

    Line 2
    char 300
    error: invalid character
    code:0
    URL:http://mydomain/wp-admin/

  11. capemaster
    Member
    Posted 4 years ago #

    Same problem here, with all browsers in all platforms. This is a server side error...
    Any ideas?

  12. AITpro
    Member
    Posted 4 years ago #

    Do you have an .htaccess file that you customized. I recently posted an .htaccess file that definitely blocks all hacking attempts and also unfortunately blocks you for some WordPress functions involving plugins and yes the drag and drop function in the widgets panel. Several of my clients had been hacked on GoDaddy so I added that very restrictive .htaccess file to their hosting accounts. By renaming your .htaccess file temporarily you should be able to determine if this is your issue. I maintain several clients WordPress sites and they are using WordPress versions 2.9.1 and 2.9.2 and the drag and drop widget function is working correctly...as long as the .htaccess file is temporarily renamed.

  13. suaveactivist
    Member
    Posted 4 years ago #

    I'm having the same problem with 2.9.2. I can't drag or otherwise modify any widgets.

    I've tried: disabling all plugins, switching to default theme, overwriting wp-includes and wp-admin directories with fresh files and have verified that I have 32MB of memory in PHP. I don't have a custom .htaccess file.

    Anything else that I can try? I'm planning to try moving back to an older version of wordpress.

  14. suaveactivist
    Member
    Posted 4 years ago #

    I just downgraded to wordpress 2.9.1 but I still have the same problem!

  15. esmi
    Forum Moderator
    Posted 4 years ago #

    Basic troubleshooting steps:

    - deactivate all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switch to the default theme to rule out any theme-related problems

    - rese the plugins folder via phpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-upload the wp-admin and wp-includes folders from a fresh download of your version of WordPress

  16. suaveactivist
    Member
    Posted 4 years ago #

    As mentioned above, I tried all of the basic troubleshooting steps with no success. I also tried using "accessibility mode" through screen options, but the screen options menu isn't accessible either.

    Is there anything else that I can try?

  17. esmi
    Forum Moderator
    Posted 4 years ago #

    Can you try uping your available memory to 64M?

  18. suaveactivist
    Member
    Posted 4 years ago #

    I've put in a request to my host support for the increase. I'll post again once they have increased it to say whether it worked or not.

  19. capemaster
    Member
    Posted 4 years ago #

    Solved for me:

    I disabled all the plugins (and it worked).
    Then I checked which was the guilty, one by one.
    And the winner is "Ajax Comment Posting" ver 2.0

    Hope this helps

  20. suaveactivist
    Member
    Posted 4 years ago #

    Upped the memory to 48MB but still no luck

  21. suaveactivist
    Member
    Posted 4 years ago #

    I just resolved the issue by installing the 'Use Google Libraries' Plugin as suggested in this thread: http://wordpress.org/support/topic/282484?replies=22

    Apparently, this means I have javascript compression issues. I don't know what that means, but am certainly glad to finally have a fix.

  22. halalan
    Member
    Posted 4 years ago #

    I believe the newest version 2.9.2 is using a NEW dashboard feature for the WIDGETS section. Where in the past you would just drag them to the specific sidebar section.

    Now, they have a EDIT option on ones already in a sidebar. You click the EDIT button then that widget opens centered in the page. You now have to tell it which SIDEBARD and WHICH position it goes to.

    Ones not on a sidebar have a EDITADD button feature.

    Also: your sidebar widgets in the dashboard seem to now not be placed right next to your available widgets but you have to scroll down because they are positioned way down to the right. (atleast for me they are)

    I personally hate that they took away the simple drag and drop approach !!!

  23. mmurtha1
    Member
    Posted 4 years ago #

    This may help some of you using WP 2.92 ...

    If you go into the widget page, and up in the right hand side of the screen right above the sidebar box(es), you should see "Screen Options".

    Click it, and you will see a dropdown menue up across the top of the screen "Enable Accessibility Mode" or "Disable accessibility mode". Make sure that you "Enable" it, and then go to the widgets.

    You should now see the word "Add" up in the top right side of each widget bar. Click "add" for each widget you want to add. You have to do them one by one, but it still works.

    Once you add a widget, a window (edit box) will pop open. It will ask what widget to add, where to add it, and what position.

    Hope this helps ...

  24. mmurtha1
    Member
    Posted 4 years ago #

    I forgot to mention, when you get done with adding all your widgets, don't forget to go up to the top of the pages and "Disable" accessibility mode.

  25. Anonymous
    Unregistered
    Posted 4 years ago #

    The screen options won't work for me either, so what I did was...
    1. Be sure you are on the widget page
    2. Append ?widgets-access=on to the end of your url.
    3. Enter

    The above forced enable-accessibility to be turned on.

    I hope this helps.

    (From "mbermas" in this post)

    It works for me !!
    I hope this helps.

  26. prsjohnny
    Member
    Posted 4 years ago #

    FIXED!!!

    Note: solution is in the last paragraph.

    Ok, I was having the same issue with my dashboard. Everything was working fine and then BOOM all of a sudden no javascript works! I tried everything that everyone suggested to do.

    1. Deactivated all plugins.
    2. Deleted all plugins.
    3. Edited line 632 on script-loader.php
    4. Fresh install of WordPress core files.
    5. Installed WordPress in another folder and set up a seperate database for it.

    And none of these things worked! So, I knew that it

    1. wasn't any plugin.
    2. It wasn't the esc_attr() function in the script-loader file. I thought it was because when I viewed the source, where it was calling the dashboard js, it was changing and the "&" to "&".
    3. It wasn't my wordpress core files. Which of coarse, I never modified them to begin with.
    4. It wasn't the content in the database.
    5. It wasn't just a fluke in my installation.

    This left 2 more things to check. The server and the operating system. I just bought a new laptop with Windows 7 which hasn't been out for very long. So, I didn't know if it was the OS or not.

    I thought it would be easier just to reinstall my Wamp Server. So I did and I'm back in business! There are a lot of topics on this subject and not one of them mentioned reinstalling Wamp as a solution. So, I'm going to copy and paste this post into all that I can find.

    Good day.

  27. duramatters
    Member
    Posted 4 years ago #

    OK, I am having the same problem, and it seems just out of the blue. I have dragged and dropped widgets as recently as last week, and then all of a sudden, not able too. I will try some of the solutions here... i have not added any recent Plugins - maybe it came from a plugin update?

  28. duramatters
    Member
    Posted 4 years ago #

    fixed mine,iIt was a plugin, WP-Events Calendar. I have not integrated it into my site yet, so no problems on that (any suggestions on an event calendar plugin?)

    Seems the problem comes up with different things with different people. The Accsesbilty Enable solution seems a great workaround if the plugin that conflicts is one you need, but I would rather not have conflicts.

  29. pehi
    Member
    Posted 4 years ago #


  30. pehi
    Member
    Posted 4 years ago #

    I found on mine that it was the translator plugin Transposh that is causing the problem and nothing to do with wordpress version 2.9.2

    If you are using Transposh plugin just deactivate and your sidebars will return and you will be able to still drag and drop widgets onto it.

    And if you don't have the Transposh plugin then it must be another one that also conflicts with 2.9.2 - so deactivate them all and activate them one by one.

Topic Closed

This topic has been closed to new replies.

About this Topic