WordPress.org

Ready to get started?Download WordPress

Forums

widgets assigned to pages keep jumping to other pages (2 posts)

  1. tallhat
    Member
    Posted 3 years ago #

    we've come across a strange problem where the widgets assigned to the sidebars of existing pages get out of sync whenever we add *new* pages to the site. (the theme we are using provides widget boxes for each PAGE of the site in the widget management area)

    to clarify; widgets - and their settings - assigned to a specific page 'jump' onto another (seemingly random) page when a new page is added to the site.

    i don't know if it's a theme problem (i wrote to the OFT theme developer who said no-one else has reported this), or if it's something more fundamental, or a slightly corrupted database.
    everything else seems to be working ok.

    it's not doing it to *all* pages, just some of them, and it seems to be a little random (although hard to tell what it's actually doing).

    anyone else ever seen anything like this? any suggestions for fixes? if the database has got it's page IDs muddled somewhere - anyone know a way of getting it to reset/recalibrate??

    it happens if we just add a *new page*. we don't have to visit the widget management page following the page addition to see the problem.

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.