WordPress.org

Ready to get started?Download WordPress

Forums

Widgetizing WuCoco (3 posts)

  1. MikeLococo
    Member
    Posted 8 years ago #

    I'm attempting to add widget support to a theme I maintain, and am running into problems. I am able to get widgets running with the default theme, to test that the plugin is functioning. In the process of widgetizing my own theme, I've added the "if... else..." line to sidebar.php and have created a functions.php to register the sidebar. Unfortunately, the "sidebar widgets" tab never appears in the presentation menu and I continue to see my static sidebar after making the changes. No errors are given and nothing else looks out of the ordinary. For what it's worth, my theme is based on another theme that did not previously make use of functions.php.

    I've carefully read the instructions at Automattic.com and am at a bit of a loss as to how to proceed. If there's any additional documentation or suggestions anyone might have I'd be grateful.

    Thanks,
    Mike

  2. moshu
    Member
    Posted 8 years ago #

    Did you close that if... thing at the end of your list in the sidebar?

    Edit. I did not "create" a functions.php - I just copied it over from a theme that had it.

  3. MikeLococo
    Member
    Posted 8 years ago #

    I did close the "if", but hadn't tried copying a working functions.php over. After doing that it worked, and I then stripped out everything but the sidebar registration bit to see if there was an extra function I was missing... and it still worked. That was the state I thought I was in before posting my question, so clearly I wasn't spotting a typo somewhere.

    Thanks for the hint and sorry for the bother,
    Mike

Topic Closed

This topic has been closed to new replies.

About this Topic