WordPress.org

Ready to get started?Download WordPress

Forums

Q2W3 Fixed Widget (Sticky Widget)
Widget width change when he start scrolling (10 posts)

  1. Thibaud
    Member
    Posted 8 months ago #

    Hi, I have tried a few hack but I cant find the solution.

    The widget width change when he start scrolling;

    So I have added a width of 225px to the class of the shortcode who is in the widget :

    .alert.general {
    width: 225px;
    }

    Uncheck it to see the problem. The problem come with firefox only..

    You can try it on this page : http://wp-infinity.com, the fixed widget start from middle of page.

    The problem with my solution is that the widget is no more responsive, and over all on that page for exemple the widget should be larger : http://wp-infinity.com/themes-wordpress-magazine/

    I also added a class to the widget :

    .rightsdb {
    min-width: 200px;
    }

    Thank you if you can help, and sorry for my english. ;-)

    http://wordpress.org/plugins/q2w3-fixed-widget/

  2. Thibaud
    Member
    Posted 8 months ago #

    Ho, by the way the page "jump" slightly when I scroll and the Refresh interval is allready set to 3000 milliseconds..

    So I don't know if the problem comes from the refresh..

    I'm working with visual composer wordpress plugin to manage rows and columns.

    Regards

  3. Max Bond
    Member
    Plugin Author

    Posted 8 months ago #

    Hi!
    I don't see th plugin is working...
    The problem is in javascript error:
    Uncaught TypeError: Object [object Object] has no method 'fitVids' (index):88
    Fix it and then I'll see how to help you

  4. Thibaud
    Member
    Posted 8 months ago #

    Should be all right now, thank you for your help

  5. Max Bond
    Member
    Plugin Author

    Posted 8 months ago #

    Yes, I see it now.

    For responsive themes you have to enable option "Inherit widget width from the parent container". But it may require css changes. Let's see

  6. Thibaud
    Member
    Posted 8 months ago #

    ok done.

    It is activated right now.. please let me kow as soon as I can desactivate this option

  7. Thibaud
    Member
    Posted 8 months ago #

    Hi max sorry I cannot check this option for too long as it break the layout.

    Let me know when you will be ready and i'll check this option in a minute for you

    Thank you again

  8. Max Bond
    Member
    Plugin Author

    Posted 8 months ago #

    Hello!
    1. Enable "Enable plugin for logged in users only" option
    2. Create a user account for me (subscriber access level will be enough)
    3. Send login and password to me from this page: http://www.q2w3.ru/contacts/

    Then I'll be able to work with plugin without making problems to site visitors!

  9. Thibaud
    Member
    Posted 8 months ago #

    Hi max

    Done, but the plugin is allready acctivated for everyone.

    You just need to uncheck

    .rightsdb {
    min-width: 200px;
    }

    and

    .alert.general {
    width: 225px;
    }

    (they are my small fix)In order to see the problem appear on firefox.

  10. Max Bond
    Member
    Plugin Author

    Posted 8 months ago #

    Hello!

    Please enable option "Inherit widget width from the parent container"

Reply

You must log in to post.

About this Plugin

About this Topic