WordPress.org

Ready to get started?Download WordPress

Forums

Testimonials by Aihrus
[resolved] Widget testimonial bleeding down over other widget content (7 posts)

  1. FrankArchitecture
    Member
    Posted 1 year ago #

    Hi

    Am using Twenty Twelve 3.5.1 Child theme .I installed the plugin and am using the sidebar widget. Am not too experienced in shortcode. I relaly like the principle of your plugin.

    MY PROBLEM

    The testimonial text overlaps and conceals the content from the widget directly under. I would like to place your testimonial widget near the top but the only way it seems to work is at the very bottom.

    Can you please let me know if there's a fix in settings to avoid this.

    Many thanks,

    Frank

    http://wordpress.org/extend/plugins/testimonials-widget/

  2. reace99
    Member
    Posted 1 year ago #

    yes shes quite messy this plugin , has cool features .. but is buggy and weird all the same.

    try this which is my styling I made for it;

    file: http://<your_site.com>/wp-content/plugins/testimonials-widget/testimonial-widgets.css

    backup your file

    then copy / paste / replace entire thing with this styling below;
    http://www.pastebin.ca/2331592

    cheers.

  3. reace99
    Member
    Posted 1 year ago #

    or.. append to bottom of your testimonial-widgets.css the following styles;

    .testimonialswidget_testimonial_list {
            display: block;
            margin-bottom: 1.4em;
            clear:left;
            padding:7px;
    background: rgb(69,72,77); /* Old browsers */
    background: -moz-linear-gradient(top,  rgba(69,72,77,1) 0%, rgba(0,0,0,1) 100%); /* FF3.6+ */
    background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,rgba(69,72,77,1)), color-stop(100%,rgba(0,0,0,1))); /* Chrome,Safari4+ */
    background: -webkit-linear-gradient(top,  rgba(69,72,77,1) 0%,rgba(0,0,0,1) 100%); /* Chrome10+,Safari5.1+ */
    background: -o-linear-gradient(top,  rgba(69,72,77,1) 0%,rgba(0,0,0,1) 100%); /* Opera 11.10+ */
    background: -ms-linear-gradient(top,  rgba(69,72,77,1) 0%,rgba(0,0,0,1) 100%); /* IE10+ */
    background: linear-gradient(to bottom,  rgba(69,72,77,1) 0%,rgba(0,0,0,1) 100%); /* W3C */
    filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#45484d', endColorstr='#000000',GradientType=0 ); /* IE6-9 */
    
            }
    
    .testimonialswidget_image{
            margin-right:20px;
    border:1px solid #000;
    -webkit-box-shadow: 0 8px 6px -6px black;
               -moz-box-shadow: 0 8px 6px -6px black;
                    box-shadow: 0 8px 6px -6px black;
    
    }
    
    .testimonialswidget_testimonial cite{
           clear:both;
           color:orange;
    }
    
    .testimonialswidget_testimonial_list p{
    padding-left:170px;
    }

    for different Gradients a good place to get them from here: gradient-editor

  4. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Frank, Have you tried setting the maximum height and adjusting your character limit to help prevent content overflow?

  5. FrankArchitecture
    Member
    Posted 1 year ago #

    Hi Michael,

    Have maximised the characters to 100 , maximum height =20 but it leaves only about two lines of testimonial and still overflows.

    Think maybe the issue relates to enabling the widget content Testimonial text to be able to push down the location of the widget directly under to avoid overflow.

    Is this possible?

    Link to site under. _ have maintained Testimonial Widget at bottom

    http://www.frankarchitecture.ie

    Thanks reace99 for your recommendations but am afraid I would do more harm than good as CSS styling is not a strong point. Am learning but slow/

    Best regards,

    Frank

  6. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Frank,

    You're trying to cram too much content into a restricted space. Think about it… How can a little box, barely 2-lines tall contain 4 to 5 lines of content.

    I would suggest trying a minimum and maximum height of 100 and then setting a character limit of 50.

    Try that and experiment.

    Michael

  7. FrankArchitecture
    Member
    Posted 1 year ago #

    Thanks will do

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic