WordPress.org

Ready to get started?Download WordPress

Forums

Rapid Twitter Widget
[resolved] Widget stopped working (25 posts)

  1. jackbloom
    Member
    Posted 1 year ago #

    The widget has stopped working as of June 12, 2013

    It had been working in WP 3.5.1.... nothing has changed on our website...

    Did Twitter change their API ??

    http://wordpress.org/extend/plugins/rapid-twitter-widget/

  2. erikas_boy
    Member
    Posted 1 year ago #

    jackbloom
    I'm not sure what you're experiencing, but as of this morning something changed and it doesn't work for me either. In my case, the script is adding a .css definition to the head of every page changing the display attribute to "none" making it's entire div disappear. I have no idea why or how to get it to stop. But it's annoying, as it's one of the best twitter plug-ins I've found, particularly as I don't want to run Jetpack on this site.
    Any suggestions from other users/creators?

  3. lazystuff
    Member
    Posted 1 year ago #

    Mine has suddenly stopped displaying anything too... any ideas why?

  4. juri003
    Member
    Posted 1 year ago #

    Twitter did retire support for several services

    https://dev.twitter.com/calendar

  5. jackbloom
    Member
    Posted 1 year ago #

    Developer..... are you out there?

    Do you intend to update your plugin to work with Twitter API 1.1 ??

    @erikas_boy what is the name of the CSS target that you're seeing?

    ahhh... I think I see it... is this the same you're getting in the source code?

    .widget_twitter--hidden{display:none!important;}

  6. erikas_boy
    Member
    Posted 1 year ago #

    jackbloom, that's the one. I suspect it might be a failover, if the plugin doesn't get a response from twitter, it hides itself, but that's just a guess.

  7. juri003
    Member
    Posted 1 year ago #

    This plugin does not use the new api.

    Good alternatives are:

    http://wordpress.org/plugins/twitget/
    http://wordpress.org/plugins/twitter-widget-pro/

    cheers

  8. erikas_boy
    Member
    Posted 1 year ago #

    Thanks Juri. I actually use your second recommendation on a lot of sites, but I took over managing a site running this plugin. If there's no word from the Devs at by days-end, I'll be having to switch.

  9. Djelibeybi
    Member
    Posted 1 year ago #

    There is a new version that uses the Twitter 1.1 API at the GitHub repo:

    https://github.com/peterwilsoncc/rapid-twitter-widget/

    Peter is aware of the API issues. There are also a couple of pull requests from me so that the widget can be used across a WordPress network without configuring a Twitter Application for each site.

  10. Peter Wilson
    Member
    Plugin Author

    Posted 1 year ago #

    Apologies for the delayed response, this is a weekend project.

    I've updated the plugin to include basic API support.

    Once you update the plugin, you need to visit Settings > Rapid Twitter Widget and to set up an application with Twitter.

    @Djelibeybi's submitted a pull request to allow for better mulit-site support, I'll be implementing that asap.

  11. j99mac
    Member
    Posted 1 year ago #

    I trying to setup the latest version of Rapid Twitter and get the fallowing error"API settings invalid. Please try again." I have added my Consumer key, Consumer secret and then that is when I get the error. How do I get the Rapid Twitter to work?

  12. Peter Wilson
    Member
    Plugin Author

    Posted 1 year ago #

    @j99mac, the only thing I can suggest is there may be a space at the start or end of on of the fields. Apart from that, I can't really help sorry.

  13. Mitch
    Member
    Posted 1 year ago #

    @j99mac, have you figured out how to make it work yet? I am getting the exact same error.

  14. nathanegraham
    Member
    Posted 1 year ago #

    multi-site support would be wonderful. Thanks for your work on this.

  15. sbbn
    Member
    Posted 1 year ago #

    Those having trouble with "API settings invalid," try again. I tried a second time after 10 minutes and it worked when it didn't the first time. No idea why it won't work sometimes but at least re-trying did the trick.

  16. Mitch
    Member
    Posted 1 year ago #

    Still no luck. Anyone have any additional workarounds? Do I need to do anything additional on the server end?

  17. Peter Wilson
    Member
    Plugin Author

    Posted 1 year ago #

    @Mitch Annoyingly, I can't replicate. If you haven't already, are you able to delete the old app and set up a new one?

    Pete

  18. Mitch
    Member
    Posted 1 year ago #

    @Pete, I tried to no avail. Can it be read-only? Perhaps I have a setting off or something. I'll try some more tonight. If anyone else has a workaround or suggestion I'm all ears. Thanks!

  19. Peter Wilson
    Member
    Plugin Author

    Posted 1 year ago #

    @Mitch I can't think what it might be sorry, I'll continue trying to break it at my end. Are you able to post a link to your site?

  20. Mitch
    Member
    Posted 1 year ago #

    @Peter, I'm wondering if it's because I'm trying to load it up on our dev site, but it was working great before the API change. Any help would be appreciated. The widget is in the footer (obviously it's empty but you can see where the tweets go).

  21. Peter Wilson
    Member
    Plugin Author

    Posted 1 year ago #

    @Mitch are you able to put this code in your theme;s functions.php to check wp_remote_get can work in your local environment? The new API requires server side code the old one didn't.

    https://gist.github.com/peterwilsoncc/db7b3d86650d1d8c60c8

  22. mlucasx
    Member
    Posted 1 year ago #

    Works great for me once I put the server side code in. Just like before.

  23. Sebastianz55
    Member
    Posted 1 year ago #

    Hello Peter Wilson,
    I'm using http://wp-radiance.solostreamsites.com/.

    I install and configure the widget but it returns ".widget_twitter--hidden{display:none!important;}". Well, I overwrite this rule and everything looks fine but I just wanted to ask how can i solve this issue so I do not force it to show.

    Additional question is if you think over the possibility to follow a hashtag in the twitter feed.

  24. Peter Wilson
    Member
    Plugin Author

    Posted 1 year ago #

    @Sebastianz55

    Tweets are loaded with javascript, the widget is hidden using widget_twitter--hidden before the javascript runs.

    Once the JS is run, the class is removed.

  25. Peter Wilson
    Member
    Plugin Author

    Posted 1 year ago #

    Marking this topic resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.