WordPress.org

Ready to get started?Download WordPress

Forums

The Google+ plugin
[resolved] Widget showing the same post multiple times (4 posts)

  1. Designer023
    Member
    Posted 6 months ago #

    I had the same problem as the previous [resolved] post. Based on the advice in there I have updated the plugin to behave correctly. I believe the custom post type was causing an issue since that is now required, but I'm no expert so don't quote me on it.

    File:
    lib/class_wdgpo_google_auth.php

    Replace @ ~line 295:

    private function _is_imported ($gplus_id) {
    		$posts = get_posts('meta_key=wdgpo_gplus_item_id&meta_value=' . $gplus_id);
    		return $posts ? true : false;
    	}

    With:

    private function _is_imported ($gplus_id) {
    		$posts = get_posts(
    			array(
    				'meta_key'    => 'wdgpo_gplus_item_id',
    				'meta_value'  => $gplus_id,
    				'post_type' => array('wdgpo_imported_post')
    
    			)
    		);
    		return $posts ? true : false;
    	}

    http://wordpress.org/plugins/google/

  2. David
    WPMU DEV Support Staff
    Posted 6 months ago #

    Hi @Designer023,

    Thanks for providing that. I'll have a look and see if we can get that updated.

    Cheers!
    david

  3. Designer023
    Member
    Posted 6 months ago #

    No problem. Glad I could be of help!

    I also had some issues on my shared hosting but that was from the Google+ API lib so it's not your issue to fix, but I just thought i'd flag it up! If you want any more details let me know and I'll let you know.

  4. David
    WPMU DEV Support Staff
    Posted 6 months ago #

    Hi @Designer023,

    Thanks, appreciate that! If it's not too much to post, I'm sure others, as well as myself, would find it interesting to know. :)

    Cheers,
    David

Reply

You must log in to post.

About this Plugin

About this Topic