WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Widget plugin + WordPress 2.3 (3 posts)

  1. mchlsync
    Member
    Posted 6 years ago #

    Hello,

    I'm getting the following error when I try to activate the widget plugin..

    Plugin could not be activated because it triggered a fatal error.

    Fatal error: Cannot redeclare register_sidebars() (previously declared in /home/.stilts/michaelsync/michaelsync.net/wp-includes/widgets.php:15) in /home/.stilts/michaelsync/michaelsync.net/wp-content/plugins/widgets/widgets.php on line 42

    After reading some posts, this error occurs because this plugin is already included wordpress core by default....

    So, if I wanna customize the widget plugin, how can I do that???

  2. MichaelH
    Member
    Posted 6 years ago #

    The Sidebar Widget does not work with 2.3, as 2.3 has native widget ability. You need to deactivate and delete the files related to that plugin.

    In the link I provided on this thread, http://wordpress.org/support/topic/139177?replies=3#post-633861 you will see reference to the wp-includes/widget.php file and that is where you would modify the native widget.

  3. mchlsync
    Member
    Posted 6 years ago #

    okay.. thanks.. it is in wp-includes..

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.